SmartThings Integration - 405 error (Solved)

Decided to change domains for my home assistant. Created domain on cloudflare. Running cloudflared add-on. I am in the process of updating all the links to my old domain. I am running into problems with SmartThings. I removed the integration and ran cleanup utility and then tried to reinstall. When I get to the step to enter personal access token I get the following error:

“SmartThings could not validate the webhook URL. Please ensure the webhook URL is reachable from the internet and try again.”

When I try loading in Chrome browser the https://domainnamehere/api/webhook I get an error that states 405: method not aloud.

Any thoughts?

Cloudflare has a “bot fight mode” that was enabled. Disabling this solved the matter. Leaving this post up in case others have the same issue.

Having the same issue - by chance you remember where the setting is for bot fight mode?


  1. Log in and go to your CloudFlare dashboard.
  2. Click on the site of interest under “Websites” on the left bar.
  3. It should now list your website URL in the top left under the cloudflare icon. Click on security.
  4. Click on Bots.
  5. You can disable bot fight mode here. The URL for this website looks like

Hope that helps.

Anyone have any other thoughts? I’ve tried all this, I was getting 405 error, now I’m getting OK 200 (tunnel response in cloudflare), but it’s still not working.

I’ve tried TLS v.1.2, Not Bot fight mode…and seemingly dozens of other solutions.