Smartthings Integration Broken

Hi All,

I’ve been using Smartthings integration for months without issue, but a couple of days ago, my integration stopped working.

To try and fix this, I’ve tried the following:

  • Updated Home Assistant to the latest version
  • Updated HassOs to the latest version
  • Deleted the integration with Smartthings
  • Run the hass-smartthings-remove python tool to remove all traces
  • Checked the Webhook is correct in the smartthings config file in .storage

But still, despite all of this, I just keep seeing “Something went wrong” when adding the smartapp…

I set the logger to Debug, but all i see is this, nothing else from the component:
2020-02-10 20:35:19 DEBUG (MainThread) [homeassistant.components.smartthings.smartapp] Setup endpoint for

There is nothing logged after that!

I’m pulling my hair out here, and I risk losing the acceptance factor of my wife - any help you guys can point me towards will be very very much appreciated, Cheers!

**EDIT: Turns out this was caused by my Pi Hole blocking some DNS queries. Fully working again now after running through the set up with the Pi Hole Temp disabled. Thanks to Jon for the idea (solution marked below)

1 Like

not working here as well

1 Like

Broken for me aswell.
Tried it all reboots, reinstalls etc. Same result.
Success in adding integration. But nothing shows up in HA.

Anyone got a hint on the cause if this?

Mine’s broken as well, and I didn’t even update. I was on 103.4 and this morning all of a sudden nothing involving Smart Things works. Since all of my Z-Wave and Zigbee devices are running through Smart Things, my entire house is basically dumb now.

I see a single error in the log that there was a problem setting up Home for SmartThings…no detail.

any chance you’re using adguard as well? I just re-setup the integration a couple days ago and it continues to be rock solid for me. If you’re using adguard, you need to disable wifi when setting up the smartapp because the domain gets blocked by adguard when attempting to install it.


Hey jon,

I use a Pi Hole… never considered that might be the issue. I’m going to attempt to re integrate this now and will update the thread shortly with the results!


1 Like

Jon you hit the nail on the head! Worked perfectly as soon as I disabled by Pi Hole… now I’m back up and running!

Thanks for the pointer - Jay.

This is the solution. Thank you!! I disabled AdGuard and I was able to re-add the smart app.
I noticed the same anomaly while using Pi-hole before it was depreciated.

sweet, glad I could help out :smiley:

1 Like