SmartThings Integration - ERROR: Something went wrong. Please try to install the SmartApp again

Hi all,

Home Assistant newbie here. I setup HASS in a docker in my swarm and got everything figured out. SmartThings connected no problem and have been loving it. Decided to make the swap to HASS full time and installed it on a RPi. Have HASS setup using HASS OS on RPi3 and I cannot get SmartThings to connect for the life of me. When going through the process, I get " This step requires you to visit an external website to be completed." which takes me to a SmartThings page that shows “ERROR: Something went wrong. Please try to install the SmartApp again.”.

I can’t find any logs to indicate the issues, and HA is available to the internet already via HTTPS. It is being proxied through Traefik with automatic Lets Encrypt certs, which is what it was doing before. The webhook URL it displays is working. The “external” and “internal” URL’s are set accordingly.

In researching this issue I’ve…

  • Used hass_smartthings_remove to clear any ST HASS SmartApps
  • Removed the cloud and smartthings config files
  • Restarted HASS and ST
  • Taken my phone off of WiFi
  • Uninstalled the ST app from my phone
  • Purged all Personal access tokens and recreated them
  • Tried to use HA Cloud instead of my reverse proxy

Can anyone give some insight so I can get my automations working again? :frowning:

EDIT: Wish I could tell you what it was, but I just retried all of those steps in one and it finally worked…