Smartthings Integration Issue - Unable to setup the smartapp. Please try it again

My system is like below;
Intel NUC 11 - HA - ST station - iphone - ST app

(all the s/w, f/w versions are the newest)

I have been trying to integrate my smartthings to HA.

I use Nabu Casa to activate HA cloud and it works fine. >> url starts from https, instead of http

Also, I made my smartthings access token properly.

But when I try to integrate ST to HA, the error message (Unable to setup the smartapp. Please try it again) keeps on.

Please help me to work this out. This makes me crazyyyyy…

1 Like

I am having the same problem. Total newbie. I have HA installed on HP t630, dedicated, no VM.
I have a Nabu Casa Account (Remote is on), and while trying to integrate Smartthings, I get the “Unable to setup the smartapp. Please try it again” error. Then, after getting a new Personal Access Token, deleting the older one, kept getting the same error.

I tried pip install hass_smartthings_remove on the HP, but got Error: unknown command “pip” for “ha”
Rebooted HA, went back to Nabu Casa, which asks for new webhook, so I tried the Smartthings integration again with the same result. The link on Nabu Casa goes to https://hooks.nabu.casa/
On Nabu Casa documentation, it notes the link should go to: https://hooks.nabuca.casa, instead of nabu.casa, possibly a typo in the documentation.

Any help on this is most appreciated.

Also, at a dead end on integrating Google Nest, but that is for another day.

I gave up on the Smartthings integration and got a Zooz 800LR Z-wave stick, and a Sonoff Zigbee 3.0 USB Dongle Plus (ZHA integration). Then, I migrated all my Z-wave devices and Zigbee devices (including all my Phillips Hue bulbs) to Home Assistant. Once that was done, I no longer needed integration with Smartthings (or Phillips Hue), so I disconnected both the Smart things and Hue hubs. After help from YouTube video “Finally! A WORKING NEST Integration with Home Assistant using OAuth!” by mostlychris, sent $5 Thanks, and completed the Google Nest integration successfully. I also subscribed to Nabu Casa Home Assistant Cloud. So I am now fully assimilated into Home Assistant, because resistance was futile.