SmartThings integrations problem

After paste token code and press submit. Nothing happened still on submit page

I’m seeing the same issue, just trying to see if I can get anything from the log to go on

I think you missed the base_url and ssl…
but I after config Base_URL and ssl… still got error after input token “Unable to setup the SmartApp. Please try again.”… any port need opened ?

in configuration.yaml

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
**http:**
**  api_password: **
**  server_port: 1111****
**  ssl_certificate: /volume1/homeassistant/cert.pem**
**  ssl_key: /volume1/homeassistant/privkey.pem**
**  base_url: XXXX.no-ip.net**

I’m getting the same issue after entering access token , ‘Unable to setup the SmartApp. Please try again.’

So I’ve been trying to fix this since it released. I used Home Assistant in a docker running on Unraid.

Initially, I couldn’t hit submit on the smartthings setup. It was giving me an error to set the base URL to https, so I did. It was just

hass.[domain]
I changed it to
https://hass.[domain]

Went through setup again and I could now hit submit. Then went I went into the smartthings classic app, I kept getting errors and there is no info on it and no long entries. I noticed though that they were pretty insistent about https so I went back through the http component setup and made sure to enter my certificates into the config. After struggling to get that working properly, when I finally started Home Assistant without SSL errors, I was able to setup the smartthings component without issue.

Why I never configured the SSL certs originally is because I kept getting unreadable errors and couldn’t figure out why HA couldn’t read them. I finally learned that the certs passed through the letsencrypt container are symlinks and that in order to use symlinks in docker, you have to mirror the location in the container. Instead of doing /mnt/cache/appdata/letsencrypt/etc/… to a folder /certs, I had to mirror the same folder structure in the container.

/mnt/cache/appdata/letsencrypt/etc/:/mnt/cache/appdata/letsencrypt/etc/

So make sure you have

  1. base_url set to https://[your domain]
  2. ssl_certificat and ssl_key properly setup and not producing errors.

After fixing both of those, the smartthings app connection worked perfectly and I now see all my devices.

That’s what I’m doing similar put the certificates in ha DIR directly and already https. But still get a message :frowning:

The base_urlfor thehttpcomponent must be configured and start withhttps://.

I got this error while trying to submit token code

@Husain I got this too, did you ever resolve it?

1 Like

I get this too and nobody ever gives a satisfactory answer. Any conversation I’ve found morphs into something else

have you figured this out? i cant get an answer anywhere. it looks like i have to enable it in the configuration.yaml but i dont know exactly what im doing for https

Having the same issue, any resolution for this ?