SmartThings Invalid Refresh Token: Steps to resolve

As per the following documented issue, I’m told this is a relatively straight-forward problem to resolve…
https://github.com/home-assistant/home-assistant/issues/22529

So apparently the process to resolve is to add the integration back to HASS using your access token (in @andrewsayre’s words).

I’m not entirely clear what this means, and am reluctant to “try things” because my system is quite reliant on SmartThings integration. I think I need to remove SmartThings integration and re-add it… but that concerns me because that might result in a significant amount of work (once re-added) in making adjustments to the many scripts and automations I have in place.

Please could someone tell me clearly what the steps are in resolving this issue so I don’t go and mess things up too much!

Thank you

3 Likes

I guess maybe I could be a bit more specific with this question:

I think I need to remove the SmartThings integration and then re-add it in order to re-authorise the refresh token (please correct me if I’m wrong). If I do that, what will I break in my configuration? Is it just the case that I would need to work through the SmartThings entities and re-set any name overrides that are referenced elsewhere in the configuration?

Pretty much-- this happens to me weekly and it’s so annoying. To the point where I’m going to just move all zigbee off of smartthings onto ZHA, I guess. Really, I would love to see this integration more robust where I don’t have to worry about refresh tokens decaying when HA startup hangs or similar. :frowning:

I was seeing “Invalid refresh token” in my HA logs for smartthings at startup (after a rollback). I was able to resolve this without deleting and reinstalling the SmartThings integration.

Open the ST app on your phone
Go to Automations
Tap the Home Assistant automation
Tap done at the bottom
On the next page tap Allow.

In the HomeAssistant UI, restart.

61 Likes

Thanks.
Worked for me

1 Like

Worked fine for me as well. Thanks.

1 Like

This worked for me too, but instead of restarting, i just disable the integration and then enable it again.

1 Like

You’re a life save! Thank you.

1 Like

Worked for me.

Brilliant, thank you it worked for me :grinning: . It was the first time that this problem had occurred for me. I have move all but one automation to HA, apart from one which uses a smart tag which doesn’t work natively in HA.

For anyone doing this now with the new SmartThings App I found a hack in the IDE as there is no longer a way to add a new SmartApp now.

You can simply past the GitHub code over any SmartApp you no longer use and it creates the Home-Assistant-Connect app in the SmartThings App.

Follow all steps from GitHub.

Genius ! Thank you , I would never have found this. I have sooooo many Automations , deleting the ST Integration and starting again would have been terrible

Great. Tnx

Reinstalling HA and ran into this. Thanks, that resolved the issue.

Worked for me, Thanks for the tip!

I have removed and added locations few times, not so nice thing. Biggest problem have been renaming all sensors after that. This helped a lot after restoring my HA from backup. Thank you so much!

Brilliant Fix, thank you.

Thanks! After this, I am more motivated to move off Smartthings to ZB

You’re a legend! Thanks!

The Smartthings app says something went wrong try installing the smartapp again.