SmartThings Multipurpose Sensor (2018) with HUSBZB-1

Just to follow up on this thread, I just disconnected my Smartthings hub and put it in the waste box. I plugged a HUSBZB-1 into my HA Raspberry Pi and configured it. When I first tried to pair the Smartthings multi-sensor, the functionality was very limited. Based on the recommendations here, I removed the device from the config and paired it with the magnet attached. PERFECT - all functionality is in place.

Thanks to all who contributed to this thread. Awesome community!

I dont want to hijack this thread, but I am looking for details from someone who’s recently got the husbzb-1 working. Are you using the zigbee home automatation integration and the deprecated zwave intregration and/or modifying the config.yaml? I’m a little unclear the best route to go here, seems like i dont need the zwave/zigbee config entries anymore? and it seem like maybe i should be using a zigbee2mqtt and zwave js instead?

I’m going to try and reset my husbzb if I can ever figure that out, as some devices just show up and I’d like to repair everything, they’re behaving oddly.

I had about the same experience as @Tibs

I got the tilt sensor working through a really janky automation where I hard coded on the axis I could tell I was rotating about.

I just used the Developer Tools → Events → Listen to events subscribed to “zha_event”.
I have not figured out how to intentionally poll the device for it’s position though. I’m only able to “remember the last place it was”

I was able to get exactly what you are describing working this week.

  • husbzb-1 (replacing a aeotech z-stick)
  • SmartThings zigbee devices
  • Z wave devices

I’m using the:

Just wanted to make this more visible to the next person who has this issue. The sensor will not pair correctly without the magnet contact being made!!! Struggled for 3 days on and off until I found this comment.

To be clear, still no X, Y, Z axis values but acceleration and temp works well.

I have a couple of these sensors and I have followed the advice to pair with the magnet next to it. This results in the temp, battery, motion showing up correctly but open/close reports as IAZ Zone and is Off when closed and On when open.

Any ideas on how to remap the device class so it correctly interprets the on / off and open / closed?


I wanted to add my own experience trying to connect a Samjin multi sensor using a Sonoff Zigbee 3.0 USB dongle. Had the above issues. Temp, Open/Close worked fine first pairing. Motion would not. I tried both with the magnet and without the magnet connected. What worked for me was going into the device screen and doing a reconfigure device. When I did this, it picked up the motion portion and is now working as expected.

I’m have a very similar issue. The open close is identified as ias_zone and the states being Wet / Dry. They do however update consistently when the door opens or closes.

Having some trouble figuring out how to specify a custom device class and previously mentioned. Any information or references to do this would be appreciated.

@Tibs .Could you please explain that with more details and the steps to achieve that. I just migrate from ST to HA and use the sensor as a garage door tilt sensor. Temp and moving state work fine. Just open / close not ! Thank you in advance