SmartThings Multipurpose Sensor (2018) with HUSBZB-1


I bought the Samsung SmartThings Multipurpose Sensor (2018) (link) and I paired it with Home Assistant via my Nortek HUSBZB-1 (link)

Temperature and open/close works, but I bought it primarily for the vibration sensor - any idea how I can get that working? Also, Home Assistant thinks it’s a moisture sensor - any idea how I can fix that?

Here’s the output of bellows -d /dev/ttyUSB1 devices -D /config/zigbee.db:
NWK: 0x223a
IEEE: 28:6d:97:00:01:00:59:f8
1: profile=0x104, device_type=DeviceType.IAS_ZONE
Input Clusters:
Basic (0)
Power Configuration (1)
Identify (3)
Poll Control (32)
Temperature Measurement (1026)
IAS Zone (1280)
Manufacturer Specific (64514)
Output Clusters:
Identify (3)
Ota (25)

I don’t know if it matters but I have a couple Xiaomi door sensors connected as well. I connected them initially using Yoda’s zha_new but I have since gone back to the default docker image (0.77.1)(homeassistant/home-assistant) and they still seem to work.

@ericstewart22, did you have any luck yet? I just started working on home assistant and used a multi sensor as my first test. I got it to connect but in my case only the temperature sensor shows a value. It does show another sensor but that one just says “off” all the time. Sadly I haven’t gotten far on this end. I should have tilt, vibration, temperature and contact switch.

Hopefully you’ve found the magic trick! Thanks.

Update, I just reinstalled HA and built it on raspbian instead of Seeing the exact same behavior although now I have bellows and other logs and tools available. Just gotta figure out what to do with them. :stuck_out_tongue: Pointers always welcome! Thanks.

Just keeping at this, there are a few things I can report from pounding bellows and zcl.

The IAS Zone (1280) is the contact/reed switch. It reads 32 for closed and 33 for open on attribute 2.
bellows zcl 24:fd:5b:00:01:0b:e6:f9 1 1280 read-attribute 2
bellows zcl 24:fd:5b:00:01:0b:e6:f9 1 1280 read-attribute 2

Some digging has led me to believe that the acceleration and axis changes are read off input 64514. However I’m having some trouble with that one. It seems that attributes should be:
18 - x axis
19 - y axis
20 - z axis

I haven’t been able to read them yet however via the CLI.

Sorry for the delay. No, I haven’t had much luck yet.

I created an issue in Yoda-x’s zha_new and he was working on it and he improved bellows support but the accelerator still wasn’t working.

Here’s a link to that issue if you’re interested:

Quick update for anyone else in the same boat as me…

zha_new is way over my head so I thought I’d give zigbee2mqtt a try since adding devices is supposed to be easy. I bought a CC2531 from Aliexpress (~$10) and flashed it using my NodeMCU 1.0 (instructions and my notes). It’s not supported at the moment but I’m working on it.

I found something out today. FYI the sensor will pickup Temp with no issue. I was having issues picking up open and close. So after I added it I removed the sensor via holding the button down 5 seconds then re-running the zha.permit; but, keeping the two parts together as if door was closed. When it repaird the door will show open and closed.

Just bought one of these samjin multis to play with on a fresh hassio instance. With default configs zha found the binary, battery, and temp entities, and those all work as expected. Vibration appears to have registered itself as an on/off entity, but I have not been able to get the data from it so far.

This would be a nice affordable node that stands out from the bunch, if the vibes worked. I am happy to help experiment with it, but not sure how to effectively go about fixing it.

I forgot to post this before, but I think it’s a good piece of info to keep with this thread. Here’s a link to a way to get 3-axis accel from a previous version of the Samjin multisensor using a sql sensor:

This may be one step closer… my newer Samjin multi sensor does have the same cluster ID for the accel, except it’s called “ManufacturerSpecificCluster”, and when I click on attributes for it, nothing comes up. I’m not very familiar with the zha integration, but I’m hoping that cluster can be ‘unlocked’ and made avilable by sending some other attribute or command?

I have this thought because my understanding on how this sensor works with a standart smartthings hub. It first is configured for “cover” or “non-cover” use, which I’m guessing sends a series of commands to setup the accel output accordingly. Perhaps this is why we aren’t seeing accel ‘out of the box’… and we just need to understand what commands/attributes are needed to enable the accel output? idk… I’m a noob by definition.

Honestly, this sensor is pretty much a paper weight in my home unless I can get the accel working. So I’m willing to experiment by sending commands etc… even if it means bricking it for the cause. Anyone got a good idea what to try? …nothing that can mess up my coordinator or hassio install plz. :wink:

Did anyone ever get the vibration sensor part figured out?

I recently received the Multipurpose sensor and am using it with the regular zha integration using a HUSBZB-1. I have a few other Sylvania lights and Aqara sensors/buttons on the network. The device paired and added correctly, however, it shows up as disconnected and for a minute and then connect for just a few seconds. When it connects, it gives the correct temp and battery. However, I don’t seem to get any notice of motion (since I want to use it as a door sensor).

Not sure if I’m pairing it incorrectly if anyone had any advice!

Not sure when or why (guessing some update that silently came through), but I was playing with my zha stuff and now everything on this Samjin multi is working perfectly with the latest hassio/hassos!

Now when I move the sensor the vibes entity correctly registers as active. When I stop moving it, about 10 seconds later it changes back to no vibes. The magnetic binary, battery level, and temperatures are also working well as they always have since I got it last summer. As I said, I’m running the latest releases (hassio 0.103.3 + hassos 3.7 + HUSBZB-1), and all I did was play around in the zha configuration page. I was checking the accel cluster attributes and noticed the x/y/z values seemed to be changing (but the entity wasn’t updating). So the lightbulb went off, I hit the button to “reconfigure device”, and a moment later the once dead entity was alive, registering movement properly!

I’m just guessing that there was some hassio update along the way that must have come with a fix for this, and ‘reconfiguring’ applied the updates to the system files. Regardless, this makes a huge difference in how I feel about the Samsung multi. I’ll be getting more of these versatile things in the future… just wish it had humidity too LOL.

1 Like

@drrayl, I’m not sure why yours isn’t working properly. Does the magnetic open/close work and just the motion not registering, or does the magnet also not work? What is your software setup (hassos, raspbian… versions)?


I was using Hassos with the Husbzb-1 stick. It seemed the sensor would register as online then drop off (show as unavailable). After updating HA and letting the sensor sit for a couple of days, it would register like normal and show as available. Not sure what happened, but it seems to work like normal now.

It could be some magical software update that sneaked in, but around this time of year it may also have to do with changes in the weather (humidity attenuates a lot). Either way, isn’t it rare and nice when something in a home automation setup fixes itself? :smiley:

I also tried to add this sensor to a home assistant running a HUSBZB-1 on Hassos 3.7 and Hassio 0.103.0, and I had the same problems as some folks in this thread:
a) the open/close was detected as a wet/dry, and
b) it only ever got a reading when it was first added and then never woke up and sent anything ever again.
Updating hassio to 0.103.6 and re-pairing the sensor fixed the latter, so now the sensor is working properly! (Thanks for suggesting that the latest patch version made a difference, @truglodite! I didn’t see anything in the change log that would be pertinent, but it sure seems like something got nudged.)
It did not, however, fix the former. So I added an override for the Device class field in the Customizations settings for that sensor, for it to be opening instead.
That did fix the problem - though at first it appeared to only partly fix the problem; it changed the icon, and the wording of the “Do something when...” automation shortcut buttons on the device screen, and stuff like that, but the state history still said “Wet”/"Dry".
As it turns out though, it displays the right values going forward, and it’s just the recorded data from before customizing and restarting that is incorrect:
So like, if you go that route to fix this problem, just don’t worry about the bit of history that was recorded beforehand, it’ll be fine :laughing:


I also used a custom device class to change that moisture default to an opening binary. Not sure how/why the quirk for this device has it defined as moisture, but oh well easy fix.

Yeah good observation on the behavior of recorder. Eventually after some time (and db purging), that ‘old data’ will eventually disappear. The catch is if you use influxdb to store years worth of data…

I had the same experience. The open/close sensor didn’t appear unless I paired the sensor with the magnet attached. Once that worked, I had to customize the device class to make it a door sensor instead of a moisture sensor.

1 Like

I am trying to switch from SmartThings to Home Assistant and have a bunch of these Centralite 3321-S door sensors I need to get working. They show the Open / Close entities, but it never changes it is always “closed”
The entity shows up as binary_sensor.centralite_3321_s_12ffba0b_ias_zone
The temperature, battery, and acceleration works nicely, but the open/close sensor never updates.
The sensors worked fine while paired to smartthings on the same doors, so it should not be an issue with the placement/sensors themselves. I changed 3 of them over to Home Assistant and all 3 are behaving the same, so I stopped changing the others over. I tried looking through the different zigbee clusters, but did not see anything that jumped out as being related

I’m stuck, and trying to find anyone to point me to some next step to try since I have tried everything I could fine.

Since this is the first thread that pops up when searching for this, Im going to give my recent experience in case someone else comes along. Its early, no coffee yet so this is gonna be rambling a bit

I’m using basic ZHA and the SmartThings hub is in the junk bin. This sensor has been the only thing bugging me and I have 68 Zigbee, 60 Zwave devices I migrated over to HA this month.

I always understood the centralite based sensor was a movement or tilt sensor when I bought them during my SmartThings period and used them as such.

Last night I set up one of them on my desk, set the SQL query to 1 second for all three axis and even went as far as to set the motion_amplification setting higher and higher and even with that it really only reports when you tilt it, lift it, “jolt” it. I suspect a washer imbalanced could set it off if laying on top. My 15 year old HE3t never really has a problem with vibration even on very high spin and I don’t think I’ve ever thrown it out of balance. So after thinking about it and reading everywhere about trying to do this, I may just put in a dry contact sensor zwave sensor for each one after looking at the schematics there is a good place to tap for voltage and “active” on both of them. Dryer needs a new drum felt ring so its a good time to do that.

For the garage door, I used Y axis query with it mounted like I would on a standard door - “up and down” for my garage doors, using a -1000 if closed, 0 if open (used the -500 as a midpoint) and it works great as a tilt sensor.

The hinge trick however looks brilliant and will likely be the best way to do that, however I DO get motion (the standard entity that is) when the weather is very windy, so its something you could use for that. Garage doors move in and out when strong bursts of winds just enough to make it go off. I think the hinge would give good open close, and movement would let me know something else is going on.