Smartthings Token Integration Error

This seems like an amazing project! I have Home Assistant 0.94 installed on my rpi 3 b+ 64 bit using Hass.io image file provided on Hassio installation page and followed the step by step instructions. I am trying to set it up to replace Stingify. I have tried over and over again without success to get smartthings to integrate with Home Assistant! I tried to set Hassio up several months ago on my rpi and it gave me same error. I have loaded and reloaded this image file several times on my rpi 3 b+ with this same result every time. When I try to “enter personal access token” to configure my smartthings hub it gives me the following error: “The base_url for the http component must be configured and start with https:// .”. Based on many hours spent reading various forms and discussion boards stating to change the configuration.yaml base url to http , https, leave it blank, put the ip address in etc and restart HA. None of this has worked for me! To be honest I am not a computer coder or expert, but I can read and follow instructions (tons of video and written instructions that all say different things!) So I am wondering if this is fixable. At this point I really don’t care if I can access this from remote locations. I just want to program it and have it control my smartthings connected devices. If there is anyone here that can point me in the right direction it would be appreciated!
Here is what I have so far:
… configuration.yaml
http:
base_url: https://XXXX.duckdns.org:8123
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

… Let’s Encrypt
{
“email”: null,
“domains”: [
null
],
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
}

… duckdns
{
“lets_encrypt”: {
“accept_terms”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
},
“token”: “xxxxxxx-xxxx-xxxx-xxxx-xxxxxxx”,

I’m having the same issue.

I opened a github issue for this https://github.com/home-assistant/home-assistant/issues/24523

Thanks so much for doing all that!

This user is not using Nabu Casa. Not the same issue.

1 Like

I am having the same problem with a slightly different setup. I am using NGINX instead of Let’s Encrypt. I tried originally with Let’s Encrypt, but “null” replaced with xxx.duckdns.org in domains. With NGINX I read that you comment out the ssl paths also; not sure about Let’s Encrypt. I couldn’t even get past the authentication form DuckDNS with that. Maybe “null” is the way to go there. I’d be willing to modify my setup if that’s the case and you get an answer.
I posted my own question since yours doesn’t seem to be getting a valid response and your setup is slightly different than mine. I don’t have NobuCasa either though. Good Luck.