Smartthings Webhook Integration Error

I followed the instructions setting up the PAT, HA Cloud and webkooks, but when I setup the integration, I get an error message.
After entering the token, the proper location (only one) is popping up. When I submit, I get a new window with an incomplete error message:

{“requestId”:“149c80cd-7df8-75bf-e974-c881f9c97a6f”,“error”:{“code”:“UnexpectedError”,“message”:“A non-recoverable error condition occurred.”,“details”:[]}}

on the web page

Did the API at Samsung change with the classic app being retired?

Looking for help to get this fixed. Thank you


I’m having the same issues. Posted about it on github and another user commented they were having the same problem. I don’t have an answer for you but it helps to know it’s not your fault. It’s something in the integration that’s not working.

Also having the same problem. I previously had SmartThings integration configured but I’m not sure exactly when it stopped working. Tried removing/re-adding the integration today and get the error.

Edit: Chrome dev tools shows a 500 Internal Server error. Per Samsung’s API documentation “A non-recoverable error condition has occurred. Indicates a problem occurred on the SmartThings server that is no fault of the client.”

there too many Joe’s in this thread already.

I’m having the same issue, I switched to Home Assistant from smartthings a few days ago and the initial integration went smooth and everything worked fine. I noticed several of my z-wave devices that were available throught the smartthings integration were no longer working. I tried removing the smartthings integration and starting over but got the webhook error.

here is my log message.

Logger: homeassistant.components.webhook
Source: components/webhook/
Integration: Webhook (documentation, issues)
First occurred: 7:08:14 PM (22 occurrences)
Last logged: 7:52:42 PM

  • Received message for unregistered webhook xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx from
  • Received message for unregistered webhook xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx from

I even completely deleted Home Assistant and all the left over config files and did a fresh install and get the same error. I’m using unraid.

edit: my smartthings setup is still working without issue.

Here’s a link to the solution. It’s a problem with the integration that will be fixed by the devs, but this will get it working for you.


I read through that thread but didnt have access to try it out until now. I feel like something must have changed on samsungs side since yesterday. I’m no longer getting that error screen in the browser anymore like i did before, however I am now having a new issue.

when setting up the smartthings integration, I input my token from smartthings (generated a fresh one), then i advance to the next screen and pick my home location from the drop down like normal. but then I no longer get redirected to the browser, I instead get a new popup window in HA that simply says “aborted”. Checking the logs shows I’m getting the same error message I posted previously. Tried the integration process from my pc and my iphone, both get the same aborted popup.

any Ideas?

1 Like

in frustration i restarted HA, smartthings, unraid, and the server its running on and generated another new token and then i got the error in the browser again and deleted the theme portion as instructed in the other thread and it worked. really strange. hopefully it doenst prove to be buggy.

thanks again.

I can confirm that this did the trick. Thank you

The direct link to the post, just in case:

O SmartThings não pôde validar o URL do webhook. Verifique se o URL do webhook está acessível pela Internet e tente novamente.