SmartThings with MQTT

I’m using the Smarter SmartThings with MQTT and Home Assistant guide. I have Docker installed on Ubuntu. Home Assistant, the broker, and Mosca istalled in containers. I have gotten past the errors, have the smart app up and running on my phone, switches are showing up on the dashboard, but no commands are sent to Smartthings.

One of the things I have struggled with is IP addresses. The articles and discussions just say IP address. Which IP addresses need to go where? I think that is where I’m failing. Is it the container IP address or Host IP/MAC address?

Ubuntu = 192.168.x.x
Docker = 172.17.x.x

Broker =
Bridge =


#MQTT Brige

# Specify your MQTT Broker’s hostname or IP address here

Port number to listen on

port: 8080

------------------------------------------ST IDE Device----------------------------------------------
Preferences (edit)
Name Type Value
ip string
mac string 02:42:ac:11:00:03
port string 8080