Smarttings integration

I saw the new component of smart things and it’s amazing.
I have a small request to add Temperature sensor support.
Also, there are sensors with 2 or more functions like motion+temp, so If it’s possible to read both of them.

Thank you!

1 Like

I’m waiting for this too, It’s coming:

1 Like

Awesome, I rolled out the dev version and now I have battery for my smartthings locks!

Are you referring to linked above?
I’ve included that on my server but I’m not seeing battery info.


Probably have to install all the component, or maybe all v0.88 ?

Copy the entire smartthings folder under your local custom_component folder.

Mostly works, just an error in log about missing Climate Platform

Locks, temp etc work ok

Did you just copy the contents of smarthings to custom_component folder?

Yes, noticed this morning the temp sensors aren’t updating but do on hassio restart. Think I’ll just wait for v0.88

I’m running HASS in a docker and I copied the contents to the following location


And now I get the following error

2019-02-16 12:28:05 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry Home for smartthings
Traceback (most recent call last):
  File "/usr/src/app/homeassistant/", line 258, in async_setup
result = await component.async_setup_entry(hass, self)
  File "/config/custom_components/smartthings/", line 83, in async_setup_entry
  File "/config/custom_components/smartthings/", line 136, in __init__
self.assignments = self._assign_capabilities(devices)
  File "/config/custom_components/smartthings/", line 148, in _assign_capabilities
'.' + platform_name, self.__module__)
  File "/usr/local/lib/python3.6/importlib/", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 994, in _gcd_import
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 678, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/config/custom_components/smartthings/", line 6, in <module>
from homeassistant.components.climate.const import (
ModuleNotFoundError: No module named 'homeassistant.components.climate.const'

I also tried setting up the integration again from scratch without any luck.

I have other items in the custom_components folder so I know my setup works with docker.

I also tried copying the files directly in the docker image (going in via docker exec and copying the files)

Any ideas?

I get same error in hassio.

Looks like it has another dependency. Think v0.88 is out next week, that has this in already.

You are correct. From the other posts it seemed like I could just pull down that folder.
I pulled the entire dev branch (0.89.0.dev0) and now I get more data.
thanks for confirming

Just updated to 0.88.0b1 and I have a lot more sensors than previously. I now have my First Alert Smoke/CO detectors.