Smoke Sensor Heiman HS1SA Zigbee Control/Configuration settings

Hi I was struggling to. I have installed Alarmo via Hacs Integrations.
In there I have made the Heiman availably under sensors. That works for me to make a alarm sound.

I’ll hope this may help you. There is a complete tutorial on Alarmo to be found.

1 Like

My sensor works correctly via ZHA and the Conbee II stick. I also just tested it with a piece of burning paper. The alarm goes of and my automation in HA correctly shuts down my devices and notifies me.

alias: Rook bij 3D printer
description: ""
  - platform: state
      - binary_sensor.heiman_smokesensor_ef_3_0_smoke
    to: "on"
condition: []
  - service: switch.turn_off
    data: {}
      entity_id: switch.shellyplug_s_3d_printer
  - service: notify.mobile_app_s23_ultra
      message: TTS
        ttl: 0
        priority: high
        media_stream: alarm_stream_max
        tts_text: Er is rook bij de 3D printer. Ga snel kijken.
mode: single

The only real issue I have is that the sensor makes two very loud beeps once a day. Sometimes it happens late at night so everybody in the house is awake. I have no idea why this is or how to solve this… Anybody noticed the same?

Hi, @jjnj

Indeed I’m having the same problem. I bought 3 of them, and randomly the give 2 loud beeps anywhere within 24 hours.
Did you ever solve this problem? Love to hear from you.
Thanks in advance.

What’s the battery level on your alarm? I’ve been told by several sources that when it starts to run out of battery it starts acting weird with random triggering the loud beeps or stop reporting to HA.

Hi, @tretabyte, the batteries are renewed. They did have this from the start… Changed them with Duracell new ones. No difference.
Changed the PollControl value to 1x per 24 hours. Didn’t help either. Moved the unit to a different location, no difference … Connected to the standard Smart Life app there’s no problem…
So somewhere in HA there is a random tricker at a random time to create this :roll_eyes:
I have 3 of them and in in HA via Conbee2 they are behaving this way. Can’t find anything strange in the logfiles either. I’m out of options at this moment :woozy_face:

1 Like

Thanks for the info @bluejobs
After my holiday I’ll look into this. Sounds like changing for me to zigbee2mqtt might solve the problem :crossed_fingers:t2::crossed_fingers:t2:
It’s going to be a lot of work…🫣

Did you try this, @Charly_X ? Have the exact same problems with alarms beeping twice now and then :roll_eyes:

I also got the problem that the alarms beeping twice now and then.
Brand new device (been up 2 weeks) battery level reports 100%

Sorry. Didn’t have the time for it at the moment. I’ll hope to try this next week​:crossed_fingers:t2::crossed_fingers:t2:

Did you happen to look into this yet?

I bought one of these about 2 years ago and it has been flawless with no random beeping at all.
I bought 3 more a few weeks ago and all of 3 of them have this random beeping issue.

Would love a solution if you’ve managed to find one.

I use a Zigbee Sonoff 3.0 USB Dongle with Home Assistant’s ZHA service, for information.

Hi I’m trying some options this weekend.
Did find out indeed that they acting the same way with the Conbee II and the Sonoff dongle with ZHA.
From the moment I connect them by a standard 3.0 zigbee gateway to Smartlife app, there’s no problem at all…
At this moment I’m not wanting to delete the complet setup with devices and entities… :upside_down_face:
So at this time 3 of them I did reset and I’m trying the fix mentioned above with keeping them alive when pairing… :v: :v: :v:
I’ll get back as soon I have a overview from this weekend!

Are you sure that the random beeping is caused by something in connection with Home Assistant?
I can not see any event registered in the logs in HA for the time the random beep occurs.

So I wonder if the device will actually do the random beep even if its removed from HA and just run standalone.

When removed from HA there are no beeps… Connected to Smartlife by Zigbee 3 gateway, no beeps.
And you are correct, there’s nothing to find in the logs :roll_eyes: :unamused:

So I’m still puzzled… I have them now running 4 days connected to Smartlife by zigbee gateway. No problems at all…But I just don’t won’t to use them that way!!

Well tried another Quirk in ZHA for this problem. Didn’t work either…
Because their is nothing in the logs, I can’t solve this.!
Last option for me, is to buy a SONOFF ZIGBEE 3.0 USB DONGLE-E and change to whole system to MQTT
That will have to wait for a few weeks…!!!

Hi, can you tell me what your firmware version is?
So from the ones that are okay? And the ones that are beeping twice every 24 hours?
Thanks in advance.

Hi, can you tell me what your firmware version is?

Thanks in advance.

Here is the one that is working in Home Assistant without any beeps at all. I’ve had this one for about a year.

And here is one of the new ones that beeps randomly:

Thanks a lot. That’s what I expected…
Firmware version 11 seems to be okay with the quirk in ZHA.
Firmware version 12 is like mine… The terrible 2x loud beeps every few hours…

Now a solution for that… How to get firmware version 11 on them instead of 12​:face_with_peeking_eye::thinking:


Hi @mdarek2 , can you tell us if the Zigbee2mgtt works fine with this Heiman? That is, NO 2 beeps every few hours?
Because that would be a reason to switch to zbmqtt… :smiley: