Snapcast Server configuration

Hi all!

I’d like to use the Snapcast server Add-on via Home assistant.
I’ve installed this add-on but it won’t start and gives (only) the following error in the log of the Add-On:

s6-overlay-suexec: fatal: can only run as pid 1

I’ve got no idea how to fix this, also can’t find any info on how to setup the configuration for the HomeAssistant Add-On.

Anyone here able to help me out in getting snapcast server to work via HomeAssistant?

My current (default) configuration is:

    - >-
    - pipe:///share/snapfifo/mopidy?name=Mopidy&sampleformat=44100:16:2
    - tcp://
  buffer: '1000'
  codec: flac
  send_to_muted: 'false'
  sampleformat: '48000:16:2'
  enabled: 'true'
  doc_root: ' '
  enabled: 'true'
  enabled: 'true'
  threads: '-1'
  datadir: /share/snapcast/

Thanks in advance!

What type of home-assistant Installation are you running?
If you have it running on a Linux, install snapserver directly on Ubuntu or Raspbian. I also tried it with the addon but never got it running…
I´m running docker-supervised.

I’m running homeassistant OS in a Virtualbox VM, that probably aint gonna make it easy to instal it directly.
Also not my preferation as i like the idea of having it all in 1 place. Makes backing up and management a bit easier (among others).

Which addon have you installed? I wanted to test it on my install to maybe provide you some details or if I have the same issue, but I was not able to find an snapserver or snapcast addon in the official addon store.
Have you imported from a custom repository? If yes, from which? You should also maybe ask there as the dev should be able to help you with the issue :wink:

I’ve installed it via adding this repo to the add on store:

this repo is a fork of raph2i/hassio-addons

where there is an issue open which mentions the same error as you have.