Snapshot from VM not restoring completely on fresh NUC install

Trying to migrate to a NUC from virtualbox VM. Relatively new/small installation, snapshots are ~150mb. Fresh install on a NUC, wrote image direct to disk, not running in docker. Only addon I installed was samba share to move the snapshots overs. Took a full snapshot from the running machine, and copied that over plus the automatic full from the night before.

Shut down VM, started up NUC. Assigned the VM’s IP to the NUC (saw someone else had trouble restoring and this solved it).

Restore process seems to go fine. Restarts fine and checking the logs I see “success.” It seems to restore supervisor addons, but that is it. I also noticed that when I go to dev tools -> MQTT under “publish a packet” it has saved the last thing I put in there from the other install, so it’s definitely bringing in data. Other than the add-ons, nothing else is there - No devices, yaml, dashboards, HACS etc.Tried with both snapshots. Have dug thru both snapshot archives and all of my yaml etc is present.

Edit; I noticed in the snapshot archive that not all of my yaml is there - specifically missing is sensors and secrets, not sure what else as I don’t have the machine up now. Could this indicate a problem with the snapshots?