Snipe-IT | Open Source IT Asset Management | HASSIO Integration Please

I would like to request the integration of Snipe-IT Open Source IT Asset Management into HASSIO.
This Open Source software can be used to keep an inventory of all your Smart Devices etc.

Here is the link to the website:

Here is the link to the Github Page:

Here is the link to the API Documentation:


Not sure if you’re still looking into this, but after a few months of refusing to settle for any other inferior asset management software, i’ve finally managed to get snipe-it installed in home assistant OS.

Here is a high level view of the steps:

  1. Install the MariaDB addon and create a db and user for snipe-it
  2. Install Portainer
  3. Go to Containers > add container, name your container, add linuxserver/snipe-it:latest to the image field and configure the environment variables based on the snipe-it docker configuration documentation > publish the network port (for host pick whatever you like and for container select port 80) > in the network configuration select hassio as the network > set restart policy to unless stopped > in Runtime & Resources set Privileged to On > create a volume for snipe-it and add it to the container volume /config > start the container.

Once the container has started, snipe-it should be accessible through the home assistant ip and the port that you’ve configured in the container configuration

Hope this helps!

Have a good one!

1 Like

I really apreciate your instructions. However, they are a bit brief since I do not have any previous experience with Docker. So I am stuck. Hope you may help me in the right direction.

The Docker image seems to be running fine, but I cannot connect to SnipeIT, I just get a timeout on the specified address (


  • Created a new, empty database in MariaDB using phpMyAdmin. Tried to assign a user to that DB in the MariaDB Add-on config
  - homeassistant
  - snipeit
  - username: homeassistant
    password: ***
  - username: snipeit
    password: ***
  - database: homeassistant
    username: homeassistant
  - database: snipeit
    username: snipeit
  • Installed Portainer, created the container according to the instructions. Except the volume, which was autocreated, so I did not use the one I created.

  • Tried to configure the Env variables - and this may be where I failed. Entering them in the Env tab in Portainer.


[migrations] started
[migrations] 01-nginx-site-confs-default: skipped
[migrations] 02-default-location: skipped
[migrations] done
usermod: no changes
      β–ˆβ–ˆβ•—     β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•—β–ˆβ–ˆβ•— β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•— 
      β–ˆβ–ˆβ•‘     β–ˆβ–ˆβ•”β•β•β•β•β•β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•”β•β•β•β–ˆβ–ˆβ•—
      β–ˆβ–ˆβ•‘     β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•—β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘
      β–ˆβ–ˆβ•‘     β•šβ•β•β•β•β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘
      β•šβ•β•β•β•β•β•β•β•šβ•β•β•β•β•β•β•β•šβ•β• β•šβ•β•β•β•β•β• 
   Brought to you by
To support the app dev(s) visit:
To support LSIO projects visit:
User UID:    911
User GID:    911
using keys found in /config/keys
[custom-init] No custom files found, skipping...
[] done.

Hi there. Sorry for the extremely late reply.

From what i can tell, you are on the right track, you have the same log output as i have so the container starts correctly.

Can you check the network that the container is using in portainer? Make sure that you use either hassio or host (whichever provides the container with its own ip address or allows it to publish services on the host ip on a specific port). Ever since i posted my last comment i switched home assistant installations and had to mess around with the networks to get it working again.

As for the env config, here’s mine:


I did have issues with accessing snipe-it in the past (on different platforms though) directly through the IP and publishing it on my domain name (secured with cloudflare access and cloudflare tunnel) did the trick. So it might be worth trying to get a free domain and configure a temporary port forward and try to access snipe-it from that domain (also replace the APP_URL with the domain before testing).

Sorry if my instructions are bad or my steps are not spot on, i’m not great at explaining things that i’ve trial and errored through but i’ll try my best to help however i can :slight_smile:

No worries, thanks for the reply! :sunglasses:
I will have a look as soon as I get the time! My guess would be that it is the network.
Then the plan was anyway to use CloudFlare if exposing externally at all. I already have CF running for a couple of HA-hosted add-ons using my private domain.