So when is OpenZWave (OZW) version 1.6 coming to Home Assistant?

I’ve been speaking to them a lot, and they have offered to update the firmware on my modules, which will supposedly fix many of the problem. However, the only way to upgrade the firmware is to send them the modules, have them upgrade, and get them back. That’s a very tedious process, with a few weeks in between where the modules are not installed. Too much of a hassle for me.

However, I was able to resolve some of the problems by changing the associations.
You have to call the zwave.change_association service twice, with these parameters:
1st call:

association: "remove"
node_id: <YOUR NODE ID>
group: 1
target_node_id: 1

2nd call:

association: "add"
node_id: <YOUR NODE ID>
group: 1
target_node_id: 1
instance: 1

I don’t suggest you to send them right now anyway, because they still didn’t manage to fix all the issues: everything works but the tilt value doesn’t get updated if you change it using the physical buttons.

Any news about implement new version openzwave 1.6 ?
And how i can verify what is now version on Hassos with Hassio ?

If you follow the instructions in my previous post the tilt value will be updated when using the physical buttons. It took me a long time to figure it out.

Your suggestion worked, thanks. Unfortunately the firmware is still bugged and reports a bogus tilt value when par 73 (Slats position) is set to 0 (UI Control).

Any news when openzwave 1.6 will be implement in HA ?


When it’s ready.


It looks like it will be replaced with a newer MQTT based system that will be able to tracker closer to OpenZWave.

Yes, I have the same configuration, and it’s indeed buggy, but still way better than before.

To use ozw 1.6 with Ha I switch to zwave2mqtt. The latest version can be find in docker version and use ozw 1.6. An auto discovery feature for HA can be enabled.

1 Like

Could you give some details on your setup? This sounds like it might help with restarting and having to modify the ozwcache file all the time and the zwave startup delay.


Could you elaborate on your setup?

Also curious how to do this… Steps?

I tried the setup for z-wave to mqtt, and found it less than desirable. It was much slower than having ha communicate directly to my devices over z wave. Lights that were being turned on/off through this method would occasionally not respond. Also when the lights responded correctly, more often than not the state of that light was not being reported correctly in HA.
I rolled my setup back to remove the z-wave/mqtt addon.

1 Like

Same here. Play with it often to check if it get’s any better after an update, but I always turn back to the default installation. Also have the problem with zwave2mqtt that when I need to restart HA, my z-wave devices don’t show up for a long time. So, I basically can not control any z-wave device after a reboot for 10 to 15 minutes.

1 Like

If you are looking for official OZW 1.6 integration in Home Assistant, 0.110 will be very promising.
Check the thread @jumpmaster posted on 27 Jan that links to the topic “The future of Z-Wave in HA”
In case you miss it - link here The Future of Z-Wave in HA - QT-OpenZWave

When completed, it looks like it may be a step ahead of zwave2mqtt.

1 Like

Folks wanting to upgrade today… please read this before you delete your zwave integration and pledge time to renaming your entities!

Yeeeeup, and sometimes much, MUCH longer than 10min…

…but the current lack of a cache file is still going to be a big problem for most users of the addon. I had to learn the hard way when I tried upgrading too early:

Today’s current addon release doesn’t have a cache file. So if you reboot host, you’ll have to stick paperclips in your aeotec gen5 recessed sensors, wait up to 4hrs for your ecolink sensors to come online, etc. This behavior will effectively break zwave dependent automations for most use cases. You’ll have to redo the old integration and rename everything a second time just to get the lost WAF back, LOL.

I have faith it won’t be long before the next release of the ozw addon brings the cache file. Other than the cache file, transferring over to ozw was relatively painless to configure. I’m sure before long, ozw will easily eclipse zwave for HA users, but at the moment it is safe to say it shouldn’t be used on anything but ‘experimental setups’ where failed automations won’t have an affect on the WAF. :wink:

That’s the risk you take if you you use beta on a production system. :slightly_smiling_face:
Many run it well and it just works with the components it supports, others have issues.
The cache file shouldn’t be such a drama as the OZW container should keep running when HA is restarted. It just speeds thing up at startup on the initial startup. 40Mins and pins in devices sounds a bit odd though. Under 1.4, one of the fixes for weird issues was deleting the cache. There could be other issues causing your mesh to be a bit unstable?
I had very few issues with the new Beta with lights and switches, no delayed start and no reset needed. I went back to the prod integration because of limited component support and some issues with ozwadmin. :slightly_smiling_face:

I am able to utilize all my devices after restarting HA as soon as the UI loads them in 0.111.

Why will this be a problem? Nevermind I see in the other thread you have many battery devices.

I’ve had to stop the ozwdaemon container today to utilize the all-in-one container, my network came back online super fast.