Socket.timeout on upgrade

Getting this set of issues when attempting to upgrade from 0.33.3. Any ideas? I don’t have masses of free space, but should be enough to upgrade. I tried it a couple of times to be sure, but same message each time. My existing system is mostly working. Having some issues with emulated Hue. I was hoping there may be some fixes

Update: Still get this when trying to upgrade to 0.35

Cleaning up...
Traceback (most recent call last):
  File "/usr/share/python-wheels/urllib3-1.9.1-py2.py3-none-any.whl/urllib3/resp", line 186, in read
    data =
  File "/usr/lib/python3.4/http/", line 500, in read
    return super(HTTPResponse, self).read(amt)
  File "/usr/lib/python3.4/http/", line 539, in readinto
    n = self.fp.readinto(b)
  File "/usr/lib/python3.4/", line 371, in readinto
    return self._sock.recv_into(b)
  File "/usr/lib/python3.4/", line 745, in recv_into
    return, buffer)
  File "/usr/lib/python3.4/", line 617, in read
    v =, buffer)
socket.timeout: The read operation timed out

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pip/", line 122, in main
    status =, args)
  File "/usr/lib/python3/dist-packages/pip/commands/", line 290, in ru
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "/usr/lib/python3/dist-packages/pip/", line 1198, in prepare_files
  File "/usr/lib/python3/dist-packages/pip/", line 1376, in unpack_url
  File "/usr/lib/python3/dist-packages/pip/", line 572, in unpack_http_url
    download_hash = _download_url(resp, link, temp_location)
  File "/usr/lib/python3/dist-packages/pip/", line 433, in _download_url
    for chunk in resp_read(4096):
  File "/usr/lib/python3/dist-packages/pip/", line 421, in resp_read
    chunk_size, decode_content=False):
  File "/usr/share/python-wheels/urllib3-1.9.1-py2.py3-none-any.whl/urllib3/", line 256, in stream
    data =, decode_content=decode_content)
  File "/usr/share/python-wheels/urllib3-1.9.1-py2.py3-none-any.whl/urllib3/", line 201, in read
    raise ReadTimeoutError(self._pool, None, 'Read timed out.')
urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host='', port=443): Read timed out.