SolarLog: how to use PV energy yield as Sensor for "Solar Collectors" (won't show up)

does anybody have an idea on how to set up the available sensor data from a SolarLog

  • sensor.solarlog_yield_day
    to be used in the Energy-configuration “Solar Yield” as an energy source?


What are the attributes of the sensor?

For sensors to be used in the Energy dashboard they should be measuring (k)Wh and have a
state_class: total_increasing

You can use Customize to add this if it is missing.

1 Like

Thanks, Tom.

The current config is listed as:

  1. state_class: total
  2. unit_of_measurement: kWh
  3. icon: mdi:solar-power
  4. friendly_name: solarlog yield total

Apparently I’m unable to find (on the Virtual Machine Web-UI) the relevant file or config to change according your proposal.
File Editor is in place but, configuration.yaml looks “default” to me.

Maybe you can help me on this as well.

Anyone else who an be of help on how to set this in the GUI?

It can’t be set using the GUI. Follow the instructions in the link. Specifically:

Ok, added this customization to the config, system has updated accordingly.
Anyhow, the requested entity was not showing up. I added

  • sensor.solarlog_yield_total:
  • device-class: energy

and will see what will happen.

Well apparently the SolarLog sensor still won’t show up at the SOLAR Collectors / Solar Production dropdown in the Energy settings.

Fun Fact: my Shelly Plug and Shelly 2.5 DO show up. As they are only consuming, not a real help :wink:

Is there any further tag or attribute that will do the miracle?

Please copy and paste the attributes you now have frim the developer-tool/states page


This is what PV generates:
state_class: measurement
unit_of_measurement: W
icon: mdi:solar-power
friendly_name: solarlog power AC

This is what my house consumes in total:
state_class: measurement
unit_of_measurement: W
device_class: power
friendly_name: solarlog consumption AC

This is what’s being fed or pulled to/from the grid:
state_class: measurement
unit_of_measurement: W
device_class: power
icon: mdi:solar-power
friendly_name: solarlog power available

I also tried the SolarLOG manual integration as posted above. Nevertheless, the sensors can’t be integrated into the Energy Dash, stating that “statistics not defined” and “entity not available”.

Those are all power sensors. It’s not the power dashboard. It’s the energy dashboard, for which you need energy sensors.

Hi tom, apart from the pasted information from the developer-tool/states page, I added following integration to my config.yaml:

Results as shown above.