( Solution) Latest Glances fail to load on Home-Assistant

Anyone having the same issue? My Glances suddently not being able to connect to HA even though its working. http://ip:61208 working fine however it fail to appear on HA sensor. Anyone can help me with this?

Error while setting up glances platform for sensor
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 249, in _async_setup_platform
    await asyncio.shield(task)
  File "/usr/src/homeassistant/homeassistant/components/glances/sensor.py", line 50, in async_setup_entry
    elif client.api.data[description.type]:
KeyError: 'docker'

Latest version Glances v3.2.5 with PsUtil v5.9.0 will create an HA error specifically due to some docker module are missing or error from glances (not HA).

UPDATE: simple solutions is to install the missing module and the latest Glances should be working without any problem.

pip3 install python-dateutil

Special thanks for KevinMo in finding the right solutions.

1 Like

Thanks for this, installing that version worked a treat!

I update the solutions for fixing the latest Glances.

I’m new to the Home Assistant environment, but running into the same issue. Where to I run those commands?

you will need to ssh to the machine that you are running. It will fixed Glances

So in my instance, I used the terminal/ssh add-on thats on my home assistant vm. I could get the first download to go fine, change directory fine, but I get a command not found for the pip3. I’m missing a step somewhere.

please check if your system used pip or pip3
if you dont have it install then you will need to install it first.

Running Home Asssitant OS. This solution does not work because additional packages cannot be installed

Hi, i have install pip python-dateutil
but glances don’t import in HA :wink:
The api work perfect from web gui…

The latest glances version should not have this problem version

1 Like

Yes thanks, i have update yesterday night :wink: