[SOLVED] Add-on: Let's Encrypt Domain change problem

Hi. Not sure if this is the right place to ask, but maybe someone will be able to point me the right direction. I am kind of a noob when it comes to SSL and encryption, don’t know how it works in the background.

First of all, as a clarification, I don’t use duckDNS, as I have static IP and I own my own domains.
I used to have my Let’s Encrypt add-on configured with my old.domain.com, and all was fine and dandy.
Then old.domain.com expired and I decided to get new.domain.com. When I configured Let’s Encrypt add-on with the new domain I noticed it was trying to renew the certificate with old config file for old.domain.com, and it was failing.

Not being able to check those config files (all in containers I understand even less than SSL), I decided to reinstall the add-on to get new config files created from scratch. And it worked. It created new files and certificates for new.domain.com, registered with authority and all that. When I start add-on again it will tell me that the certificate is not for renewal yet. So all is good…

… but I have no padlock in a browser. When checking new.domain.com on a service whynopadlock.com it is showing two main errors:

  1. Your SSL certificate does not match your domain name!
    Protected Domains:

  2. Your SSL certificate is expired! (Expired on: 2019-04-25) You will want to renew your SSL certificate as soon as possible!

So something is not right. I have waited 24 hours, and still no padlock.

Do you have some experience with this? Can you point me to how to fix it?

Did you try rebooting? Your web server is still using the old certificate.

Of course I didn’t! Why would I?? I’m a moron!

I only rebooted it like million times just before renewing certs, but not once after.
All green now, thanks!

1 Like