[solved by powering off some time] Zigbee: problem with lights after power outage

There was a power failure earlier today and my zigbee network has issues.
Most of the lights don’t respond, some with delays others are just OK.
Of the wireless devices most seem to still work fine.
Even in z2m, lights don’t respond.

I have restored a working backup from z2m but no difference.
HA & z2m run in separate LXC’s.

What could be wrong?
Any help is highly appreciated!

EDIT: changed the title from z2m to zigbee since whatever I did with the integration didn’t bring any improvement.

I understand that sometimes one doesn’t have a clue where to start, but this will not help anyone to help you.
Pick a one light and pair it again. See if that helps.
Maybe zgibee network needs some time to bring everything back and set the mesh routes.

1 Like

Hi Daniel, thanks for helping!

I was wondering what could be done to troubleshoot such a situation and if I could learn something new about zigbee/z2m.
About paring again: do I just pair without changing anything in z2m - so not delete the device to create it again?

Have you tried a simple restart of z2m and powercycle of the coordinator. It might be in a wrong state?

1 Like

Just pair it don’t delete anything.

1 Like

After paring the faulty lights again, it seems that everything works again.

What puzzled me: some lights were working one time and shortly after that I got errors in z2m for the same lights.
I also couldn’t display the map in z2m: it didn’t load.

I restarted z2m already which didn’t change anything and then I power-cycled the coordinator (thanks for that tip @khvej8)
Let’s see how it goes the next 24h.

Thanks a lot for helping guys! :bowing_man:

It is not Z2M or the coordinator which causes the issues most of the time, but poorly written firmwares and low quality hardware.

If I can guess, you most likely have some IKEA Tradfri lights, sockets or repeaters, as they tend to do this kind of things. (Or some similar low budget ones, like Osram Smart+)

Most of the cases just restarting some lights solves the problem (turning off for 10-20 seconds, then back on the power).

I would not advise to re-pair any lights, if you use Xiaomi or Aqara end devices (temp, open/close, motion sensors), because re-pairing means reseting the device first and those end devices do not really adhere the mesh concept of Zigbee. The only case when I would advise to reset/re-pair if the light goes into a continuous announcement cycle and flashes regularly showing the it has connected to the network.

1 Like

I have a lot of xiaomi zigbee devices and I don’t understand what do you mean by re-pairing means resenting the device. How exactly this should affect device, data or zigbee network?

Xiaomi devices usually stick to that parent what they first connected/paired through. If that parent is reset, it is quite likely that the Xiaomi device will fall off the network and will not reconnect through the same parent or any other parent, unless you force it.

As Zigbee any device should seek a way to communicate with the coordinator if the parent is lost. But it is unfortunately not always the case.

I don’t know. I tried to test this and re-pair one of my xiaomi smart plugs that acts as a router. End devices disconnected from it. Some of them are xiaomi devices but they connected to another router. But some of end devices that was not connected to this router disconnected and than reconnected to zigbee network. It took between 5 and 10 minutes for them to connect but majority of them connected to another router. My temperature sensor connected to the same router but its 50 cm from the smart plug.

I see this all the time with Xiaomi (Aqara) open/close, leak sensors and buttons. They tend just to drop off and never connect back

I can only say I don’t know. I’m sure that there is an issue and I believe you. But the problem might be in combinations of routers, end device and coordinator and firmware. I have 80 zigbbe devices, xiaomi, tuya, moes, ewelink and some other Chinese I don’t know what.
Battery powered devices rarely disconnects from the network. Usually this happens when I play around with my ha, restarting it, or changing something in docker containers. But I didn’t noticed that they drop off network on its own. This only happens when battery is low and is wrong reported as 100%. Changing battery fix the issue.
The only thing I noticed that have problems is light switches. Some of them can became unavailable in lovelace because they report status using mqtt. But in the same time they are available in z2m and can be controlled. If I toggle the switch in z2m it became available in lovelace.
Smart plugs and smart outlets never disconnected from the network.
I have zStack3x0 coordinator.

I experience this mostly with IKEA bulbs and socket, or Osram Smart+ bulbs, the Tuya ones are the most reliable. The Sonoff ZB Mini is questionable also. But the Aqara devices drop off and do not reconnect in combination with the cheap low quality devices.
Re-pairing usually causes me issues (especially after power outages, which mess up everything…)

Thanks guys for helping!

Everything is working again and at first I thought it was only the lights that acted strange but I discovered a little later that 1 wireless remote also exposed strange behavior.

@GSzabados: you are a visionary, they are indeed IKEA lights and the remote as well.
Removing the power for some time seemed to have solved it finally.

I got rid of most of them due to this behaviour.

Did you experience this multiple times?
So far I was happy with the price vs quality with these bulbs, this is the first hiccup.

I did experience it multiple times when power outages happened, or one someone turned off one of the lights directly at the power. I always hoped that the newer firmware(s) solve it, but unfortunately didn’t.

There used to be some bugs with the bulbs, when used in bigger meshes they tend to crash. I don’t know that have they been fixed.

I get rid all of the sockets also. Some started to go into a cycle when they continuously turn on and off. They were just a safety hazard.

Ok, that makes sense to get rid of them!