[SOLVED] Cannot add ConBee II device in ZHA

Hello All. I am having a bit of trouble and I hope someone can help.

I have just purchased a new ConBee II device. I initially added the device to HA using deCONZ add-on via Supervisor and everything went well. For my part though, I didn’t like the non integrated look and feel and then noticed that HA itself had found my device automatically and there was an official integration.


Unfortunately I cannot get past the initial setup of the device via the official integration.

If I try and Setup via the Wizard after automatic discovery:

  • Go through to Integrations via Notifications
  • Click Configure
  • Box asks “Do you want to setup ConBee II - /dev/serial/by-id/usb dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II etc…”
  • Click Submit
  • Spinning Blue Circle where the Submit button was
  • Box comes up after about a minute saying “Aborted”

If I try and setup by adding an Integration:

  • Add Integration>Zigbee Home Automation
  • Box comes up asking me to choose device serial path (3 in list, one is Add Manually)
  • Select only option that makes sense “/dev/ttyACM0 - ConBee II etc …” and Submit (not this is note a /dev path as per the first method which is what I would be expecting)
  • After what appears to be a fair while
  • Box appears to choose Radio Type. Choose deCONZ and Submit.
  • Box appears asking me to choose device serial path (again), this time the path is a /dev/serial/by-id/usb-dresden etc … path
  • Click Submit and get an error “Failed to Connect”

Things I have tried:

  • Grabbing the /dev/ path from the command line and adding Manually (thus avoiding the /tty paths) - same result
  • Using the /tty path exclusively - same result

My Logs show:

Method 1:

Retry command 0x0002

1:49:51 PM – (WARNING) /usr/local/lib/python3.9/site-packages/zigpy_zigate/api.py

No response to command 0x0002

1:49:51 PM – (WARNING) /usr/local/lib/python3.9/site-packages/zigpy_zigate/api.py

No response to ‘Command.device_state’ command with seq id ‘0x02’

1:49:50 PM – (WARNING) /usr/local/lib/python3.9/site-packages/zigpy_deconz/api.py

Method 2:

No response to ‘Command.device_state’ command with seq id ‘0x02’

1:53:02 PM – (WARNING) /usr/local/lib/python3.9/site-packages/zigpy_deconz/api.py - message first occurred at 1:52:03 PM and shows up 2 times

No response for: SRSP SYS version {}

1:52:10 PM – (WARNING) /usr/local/lib/python3.9/site-packages/zigpy_cc/api.py

at: No response to AP command

1:52:09 PM – (WARNING) /usr/local/lib/python3.9/site-packages/zigpy_xbee/api.py

Retry command 0x0002

1:52:07 PM – (WARNING) /usr/local/lib/python3.9/site-packages/zigpy_zigate/api.py

No response to command 0x0002

1:52:07 PM – (WARNING) /usr/local/lib/python3.9/site-packages/zigpy_zigate/api.py

Do you still have the Deconz integration running ? Only one integration can use the stick at the same time.

A key piece of the puzzle was that I am running through a Virtual Machine on unRAID.

I was able to solve the problem by adding the device as a serial-usb instead of the default.

My code was:

    <serial type='dev'>
      <source path='/dev/serial/by-id/<yourusbid>'/>     <----note this is the host path
      <target type='usb-serial' port='1'>
        <model name='usb-serial'/>
      <alias name='serial1'/>
      <address type='usb' bus='0' port='4'/>

One I did this - it didn’t auto discover but I was able to add the integration in 2 clicks. Now time to test but seems resolved for now.


@danioj I am a noob. I’m trying to overcome the same problem you’ve had…or so I believe. Can you tell me where you inserted the code you reported in the stream?

Some background:

I am running HA OS in VirtualBox on a Win10 host. I could add the Conbee II in WIn10 Device Manager. It came online as COM8. When the VM started up, it would erase COM8. Every time. After fiddling for a while, I realized the VM only recognized 4 COM ports, so in Device Manager, I reassigned the Conbee II to COM2. Although COM2 also disappeared, when the VM started, the Zigbee radio and both of the Zigbee devices I had installed were auto-discovered. Problem solved. Except… when I had to restart the Win10 host, everything went back to square 1. Long story short, I’m looking for a means of installing the ZIgbee radio that won’t break every time the host machine restarts.

IS your solution still viable?

1 Like

Awesome, you are my hero :slight_smile: I had the same problem in unraid and this worked!

Hello there same problem here and same question about your code, where do i insert this xml?

fixed for me with this solution.
the xml need to be used to manually attach the device to an usb port on the VM
for KVM the command seems to be :
virsh attach-device <yourVMname> --file /home/pi/<yourfile>.xml

No discover mode available, but ZHA integration detect the device and it works

If anyone comes across this post and are using Unraid then I really recommend you to use the USB plugin for fixed allocation to your HA VM installation!

Happy to support Plugin Devs all. Here is what casperse is referring to:

Personally, I preferred my method but it’s great to have options.

I don’t use this solution anymore though as I’ve migrated my BlueIris, Home Assistant, Pfsense and UniFi / Pihole Dockers to Proxmox.

Im now keeping my critical stuff away from unRAID due to the limitations linked to the array needing to be healthy and running before virtualisation services can start / keep running.


Wow, I spent around 4 hours trying to get my conbee II stick connected to Home Assistant (through ZHA, deconz, zigbee2mqtt). I went with the conbee II because I thought it was considered a “better” more “trouble free” zigbee stick. I ordered new sonoff zigbee USBs, but I may go cancel it now that it is working with my ConBee II

I tried your code earlier and it didn’t work (I am running on an Ubuntu host with HA via VM). Eventually, it resolved my problem. I hope this can help others save some of their precious time if they run into a similar scenario.

Note, the bus and port from your code do not need to match the physical USB location in your VM/system.

I had previously modified my VM XML to include the following code as well:

    <hostdev mode='subsystem' type='usb' managed='yes'>
        <vendor id='0x1cf1'/>
        <product id='0x0030'/>
      <address type='usb' bus='0' port='2'/>

This code didn’t resolve anything, DO NOT ADD IT (well, maybe if you have a different issue) but it was causing issues for me.

Note ZHA and deConz were previously “recognizing” the zigbee stick and giving it an ID of:


This would NEVER connect. Once I removed the hostdev XML and added the serial XML my zigbee device gave me a new location


and id of


now, I can connect my conbee II stick to deCONZ, ZHA, etc.

Omg, :smiley: thank you for your solution! This solved my issue I had on a KVM virtual machine hosted on ubuntu server.

Note, if a problem is made after a while, just change the port number located in the ‘target’ section. I used 5 after the system disregarded the conbee stick when using 1.

Created an account, just to say thank you! Really helped me after being stuck. Using a HA on a VM with USB pass.through.

1 Like