[SOLVED] Cannot re-onboard iPhone

I’ve done a clean install of iOS 15.0.2 on my iPhone 11 Pro. I forgot to rename the phone to match its name before the reinstall, which is what the Mobile App integration was assigned to. So I ended up with duplicate integrations. As I have all sorts of automations tied to the original entity names, I wanted to zap all Mobile App integrations and start over.

I can’t do that. The onboarding process just cannot be re-run. Whenever I try to re-onboard, the old (original) “iPhone” integration just comes back, but does not reflect the current state of the phone (states are “Unknown”, outdated, unavailable…)

I tried:

  • uninstalling and reinstalling the Home Assistant iOS app, with reboots after uninstall
  • restarting HA
  • removing leftover entities from HA - there are none
  • manually removing entities from core.entity_registry and core.device_registry

HA 2021.10.6 on Rpi4, HA app 2021.10 on iPhone 11 Pro with iOS 15.0.2

Any tips? I’m helpless and need this to work. Thanks!

SOLUTION: there’s a “Restore” button in the App Configuration (in the iOS app) → Debugging. That zaps everything and launches onboarding on the next launch of the app. After that, some entities and their old states from the previous integration come back from the dead, but seem to slowly update as new states are coming in. MAKE SURE YOU NAME YOUR IPHONE (in Settings - General - Information) THE SAME AS BEFORE SO THE ENTITIES STAY THE SAME.

1 Like

Thanks for posting this. I’ll be googling for this very issue within a year, I expect.

1 Like