[Solved] Can't install hass.io, hassbian or hassos, get all kinds of weird errors - how to proceed?


#1

Hi!
I’m trying to install Home Assistant in one form or another on a Raspberry Pi 2 B or 3 B+ (yeah, I realized just too late that it was the wrong one).

At first, I tried installing hass.io on a B+ using https://github.com/dale3h/hassio-installer. I got the “preparing HASS.io” page, but after 20 minutes or so the page reloaded and timed out.

Then I tried hassos, but got some error messages about ports not being ready.

So I found a RPi 2 B and fired it up with Hass.io, thinking it would be super easy as now I finally had an officially supported device. Turns out it wasn’t, as the “preparint HASS.io” page would never go away.

So finally I tried Hassbian on the RPi 2, but for whatever reason (tried both with an Ethernet cable and without (using wpa_supplicant)), it didn’t actually download HA, but booted and let me log in in about thirty seconds.

As a last resort, I booted up a Latte Panda with Windows 10, and downloaded Python and HA for Windows. It works on my Lenovo laptop (that’s the whole reason I haven’t given up yet), but would just not load the frontend on that.

I’ve googled all these issues like crazy, and tried any workaround that I could find, but all to no avail.

Does anyone have any idea of what I am systematically doing wrong? You would think it’s the network (and it could very well be), but I’m still able to fire up and run HA on my Lenovo laptop on the same network, so it’s not AP isolation or anything.

(The power supply is a 4 A OnePlus dash charger, with an original OnePlus One cable.)

Update: So I finally got it working on my 3 B+ (with the same charger, and still on wifi-only) using Raspbian Stretch (desktop version) and https://www.home-assistant.io/docs/installation/raspberry-pi/.