[Solved - check zstick firmware is up to date] 3 systems work with smartstart - 1 does not

Hi all zwave lovers out there.

Like I say in the subject I have a weird situation where one of the 4 machines with zwave I’ve setup for family and friends does not present a QR code/smartstart option to add a zwave device.

Only noticed when trying to add a windows sensor that is the first battery powered device at that location. The same sensors as I have at my home that I was only able to add when using the QR code option.

I’ve compared the 2 machines configuration.yaml and things look correct but I must be missing some component that smartstart requires.

Any ideas? Screenshot attached from problem machine…


and the option is just not there. Screenshot from my working machine…


Thanks in advance! :beers:

I should have mentioned - All systems running the official Z-Wave JS addon - up to date supervised installs on raspberry pis.

Are doing this from the app or a web browser? Try clearing your cache.

Multiple browsers tried - I’m able to remote in using my PC but the machine at that house did the same.

App also failed to present my friend the QR option but unfortunately I don’t have the app available to me as this is not my house.

Thanks for the reply tho - always good to start fresh

You have not mentioned what controllers you are using. Are they identical? SmartStart is not supported in older controllers. For example, the Nortek HUSBZB-1 and Aeotec Gen5 with fw < 1.2.

Another valid point - the 2 systems I took screenshots from both use Aeotec Z-Stick Gen5+

by AEON Labs
Firmware: 1.2

Ah-ha! The problem location seems to need the latest firmware update.

by AEON Labs
Firmware: 1.1

Thanks for that pro tip freshcoat.

Will try to get that updated this weekend and mark this solved if that makes the magic happen.