[Solved]Cleaning code in SD Card on MAC. Pi won't boot

I have Hassbian installed on my PI, for some reason I screwed up with cron, and can’t get Pi to boot. I’ve Already tried to mess with the SD card with fuse-ext2, mac-fuse with no success. The only way I could achieve something was with Paragon Software, but I only have read permission on the SD card. I can see the “bad code”, but I can´t remove it from the cron file. Also tried with ubuntu live with no success, because ubuntu can’t mount the partition for some reason. Please share some light.

Solution was on updating the e2fsck to the current version in ubuntu, after that I could mount the partition and delete the cron file.
Just in case someone runs into the same problem as me.

Running in to the same issue - can you give any insight on how to you upgraded e2fsck on Ubuntu? None of the instructions I’ve tried have worked. Thanks!


Try This:


tar -xf e2fsprogs-1.43.tar.xz
cd e2fsprogs-1.43
make install

e2fsck -V
e2fsck 1.43 (17-May-2016)

EDIT: I had to manually download the tar file, wget was not working

That did the trick and I was able to recover my SD card. Thanks so much!