[SOLVED] Companion app connects AT MOST ONCE


I set up reverse proxy with DuckDNS + encryption. I forwarded port 18123 to internal port 8123 on Hass server. From a browser (PC, my phone), both external and internal addresses work perfectly well.

But the companion app (full flavor) only manages to connect once (sometimes not) right after I set it up, and then no more if I close/open it. I just see the blue header at the top, no menu, no text. After a few secs, a message pops up where I can chose to review the parameters or wait.

Same for internal and external addresses. I tried multiple times to start fresh, but no change.

I have Android 7.

In the app log, I could see syntax error line : unexected token “import” , then my external DuckDNS address.

Any idea ?

are you certain that everything is being proxied properly? The companion apps rely on more than just the frontend pieces to work.

this page might be of some help: https://companion.home-assistant.io/docs/troubleshooting/networking

Thanks for the link. However, I didn’t see anything to forward but port TCP 8123, which I did.

Here is the log file from the app : --------- beginning of main08-22 22:26:10.342 15054 15054 I art : Starting - Pastebin.com

Perhaps line 140 is interesting. The URL https://MYDOMAIN.duckdns.org:18123/?external_auth=1 (I changed my real domain name before sharing the log) gives an error in a browser too.

Well, uninstall, reboot, install made it work. It has been working for a couple of days now. Strange…