SOLVED: Core 2021.1.0 to 2021.1.5 update fails

Tags: #<Tag:0x00007f325d009948> #<Tag:0x00007f325d0096f0>

Hi! Newbie here, so please bear with me. I’ve been running Hassio on Rpi3 for about a year without problems. So far, I’ve successfully updated my system every couple of months. But now I’m not able to update the Core from core-2021.1.0. Also, I always get a timeout, when I’m trying to import Blueprints, or add automations. I tried rebooting the system for a few times, but that didn’t help.

Could someone please help me get this running again.

This is my system:
Home Assistant OS 5.10
supervisor-2021.01.7
core-2021.1.0
Used Space: 29.5%

Here’s the supervisor log when I’m trying to update the Core:

21-02-02 20:56:30 INFO (MainThread) [supervisor.homeassistant.core] Updating Home Assistant to version 2021.1.5
21-02-02 20:56:30 INFO (SyncWorker_3) [supervisor.docker.interface] Updating image homeassistant/raspberrypi3-homeassistant:2021.1.0 to homeassistant/raspberrypi3-homeassistant:2021.1.5
21-02-02 20:56:30 INFO (SyncWorker_3) [supervisor.docker.interface] Downloading docker image homeassistant/raspberrypi3-homeassistant with tag 2021.1.5.
21-02-02 20:56:45 ERROR (SyncWorker_3) [supervisor.docker.interface] Can't install homeassistant/raspberrypi3-homeassistant:2021.1.5 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2021.1.5&fromImage=homeassistant%2Fraspberrypi3-homeassistant: Internal Server Error ("Get "https://registry-1.docker.io/v2/": context deadline exceeded (Client.Timeout exceeded while awaiting headers)").
21-02-02 20:56:45 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed
21-02-02 20:57:02 WARNING (MainThread) [supervisor.jobs] 'Updater.fetch_data' blocked from execution, no supervisor internet connection

Now that the core-2021.2.1 was released, I was able to upgrade to it without problems.