[Solved] Creating a second user

Hello There!

I recently upgraded from 0.72ish to 0.83 and I’m trying to use this newfangled account system.

I’ve successfully created an account for myself but when I try to create a second one I see this:

Any idea where I’ve gone wrong?

Are you logged in? or did you log in with the old login prior to auth?

I’m logged in with my new account.

   - type: homeassistant
   - type: legacy_api_password

In your Profile, does it say:

You are currently logged in as YourNameHere. You are an owner.

If some odd reason it doesn’t recognize you as an owner, you won’t be able to create additional accounts.

NOTE: To view your Profile, click the icon with your initials in the upper-left hand side of the menu.

Looks like Home Assistant doesn’t recognize your account to be an Owner (and so you can’t create new accounts).

I have to admit that I’m not sure what the next step is to grant your account Owner privileges. A brute-force way would be to re-install Home Assistant (and have the on-boarding process create the Owner account) but there must be a more elegant way!

As @123 said, you need to be owner. Owner will be the first user you created when Auth was introduced on your system.

Right, I solved this:
First I removed the “auth_providers” section from my config file, it’s no longer needed after 0.77 or so.

Then I deleted .storage/onboarding and .storage/auth* and rebooted.
The system allowed me to create a new user and this time I was an Owner, then I was able to create second and third accounts! :+1: