[SOLVED]Deconz groups don't appear as entities


I have set up home assistant, a conbee II and deconz. Hassio is installed on a intel nuc, The process went smooth, and I can control all lights through Deconz. Sadly the groups don’t appear as entities in Home Assistant. Causing troubles when I want to control them with adaptive lightning and so on.

I can’t identify the problem and I don’t know how to proceed. I’ve tried to search through the forums and google without any results.

I have noticed the conbee at times have difficulites during configuration. Here is the log:

> Couldn't start deCONZ = dresden elektronik deCONZ protocol: ConBee I/II, RaspBee I/II coordinator
> Traceback (most recent call last):
>   File "/usr/local/lib/python3.9/asyncio/tasks.py", line 492, in wait_for
>     fut.result()
> asyncio.exceptions.CancelledError
> The above exception was the direct cause of the following exception:
> Traceback (most recent call last):
>   File "/usr/src/homeassistant/homeassistant/components/zha/core/gateway.py", line 152, in async_initialize
>     self.application_controller = await app_controller_cls.new(
>   File "/usr/local/lib/python3.9/site-packages/zigpy/application.py", line 69, in new
>     await app.startup(auto_form)
>   File "/usr/local/lib/python3.9/site-packages/zigpy_deconz/zigbee/application.py", line 67, in startup
>     self.version = await self._api.version()
>   File "/usr/local/lib/python3.9/site-packages/zigpy_deconz/api.py", line 463, in version
>     (self._proto_ver,) = await self[NetworkParameter.protocol_version]
>   File "/usr/local/lib/python3.9/site-packages/zigpy_deconz/api.py", line 428, in read_parameter
>     r = await self._command(Command.read_parameter, 1 + len(data), param, data)
>   File "/usr/local/lib/python3.9/site-packages/zigpy_deconz/api.py", line 313, in _command
>     return await asyncio.wait_for(fut, timeout=COMMAND_TIMEOUT)
>   File "/usr/local/lib/python3.9/asyncio/tasks.py", line 494, in wait_for
>     raise exceptions.TimeoutError() from exc
> asyncio.exceptions.TimeoutError 

And this:

> Logger: homeassistant.config_entries
> Source: config_entries.py:366
> First occurred: 21.21.12 (2 occurrences)
> Last logged: 21.21.17
> * Config entry 'ConBee II - /dev/ttyACM0, s/n: DEXXXXXX - dresden elektronik ingenieurtechnik GmbH - 1CF1:0030' for zha integration not ready yet; Retrying in background

I hope somebody has the answer, so my girlfriend will stop bugging me with all comments about how easy I can control our lights. Thank you!

I can’t say anything about the error, bit have you allowed HA to use DeConz groups? Integrations page > “configure” in the left bottom corner of the DeConz integration’s window.

Thank you for quick suggestion.

Yes, it is activated :frowning:

Quite embrassing.

I just figured that I didn’t install Decconz as an integration, but only as an add-on… Problem solved

:grinning_face_with_smiling_eyes: Glad you found a solution.