SOLVED: Develco Smart Plug Mini SPLZB-131 reconnect problem

I have Home Assistant installed in a docker container on a Raspberry Pi 4. I have connected the ZigBee device (v3.3 of a zigbee stack in firmware/I haven’t touched it) via an extension cord and it has the big antenna. HA found the device right away (very nice!) and I proceeded to add a relay (Develco brand). This also went flawlessly! I am quite impressed by that.

I had to move the relay to a different socket and I just unplugged it and plugged it into the new socket. This is where it stopped being so impressive because the ZigBee client wasn’t detected after the switch. It remained in search mode, searching for the coordinator, but seemingly never found it as it didn’t exist the search mode (could be misinterpreting it here). Eventually the search mode stopped on the client. Before it stopped, I tried turning off/on the relay. Some command got through with a delay, but most didn’t. None got through after the search mode ended.

I tried various stuff, but what turned out to work was to factory reset the ZigBee client when it is powered up combined with adding a new client in Home Assistant. The device will be found and the existing setup is reused.

But this cannot be how it is supposed to work, right? Is there anything I can do so a configured ZigBee client will be able to reconnect after it has been power cycled?

“Switch”? I assume that what you mean is that you physically moved a mains-powered Zigbee Router (ZR) device product (like an IKEA Trådfri Wireless Outlet smart power-plug) from one area/location in your house to a different area/location in your house, or? …“switch” means a switch device class in the world of Home Assistant →

Zigbee network uses mesh technology which means it remembers its neighbours + last connection paths and it usually takes about 1-hour before a Zigbee End Device (ZED) and Zigbee Router (ZR) devices will try to reconnect via a different path if you physically move them to a new location in your home, which is why it is generally recommended to pair Zigbee devices in the final location or manually re-pair them if you move them, even though simply power-cycling the Zigbee device will work for many products from most manufacturers (there are however so many different Zigbee device hardware platforms and developer choices that each device can be unique in the way that work). Read the best practices here →

Blakadder and Zigbee2MQTT both have community-maintained device databases that try to collect tips about unique pairing, information, and issues about specific devices, check them out to lookup specific device(s) → and

Regardless it is also always recommended to use best practices to avoid interference and optimize your Zigbee network mesh by adding a few “known good” Zigbee Router devices as a combination of interference and/or poor reception is often the root cause for intermittent issues →

Suggest that you also read and follow an extension of those tips here → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

Otherwise, it is kind of hard to know exactly what you mean because you are not using the correct terminology for Zigbee, (which is understandable since its terminology differs from other common technologies), and that makes it difficult for others to help troubleshoot. Please try to use the correct terminology for Zigbee if the future, see → (and perhaps even consider reading

For example, when you write “ZigBee client” do you mean the ZHA (Zigbee Home Automation) integration which is really the “Zigbee gateway” (as in the application layer implementation which architecturally speaking would be the controller with the Zigbee Coordinator being the “master” as Zigbee devices which need a Zigbee gateway application to work with a Zigbee Coordinator). Zigbee does not use a server-client model architecture so saying “ZigBee client” does not make sense and it will not help you if people have to guess from context what you mean. Help us help you!

And when you write “relay” do you mean a “Zigbee Router” (ZR) device which is sometimes referred to Zigbee signal repeater or Zigbee signal extender (which most mains-powered devices normally are)?

Also assume that you referring to Zigbee Coordinator USB adapter when you write “ ZigBee device” you mean your “Zigbee Coordinator” USB adapter (as in the RF gateway/bridge and central controller or “hub”)?

And I assume that you mean “join mode” or “pairing mode” when you write “search mode”?

Thank you for the reply. It is appreciated.

I know I am am most likely using the wrong terminology but hoped my meaning could be deducted from the context.

I have 2 ZigBee devices. First device is the coordinator ( and the other device is the relay (Develco Smart Mini).

HA discovered the coordinator automatically. I added the Develco relay. It worked just fine. No issues at all. On/off commands are received right away and when I toggle the relay by pressing a button on the Develco relay, it sends the new state to HA right away. 2-way communication works just fine.

Then I powercycled the Develco relay and it fails to rejoin the ZigBee network. The Develco relay keep blinking for a few minutes searching for the coordinator and eventually gives up. As the relay is an always-on device and can act as a router, I expect it to reconnect after a power failure without manual intervention. It does not. It is as if the coordinator ( doesn’t know about the relay anymore. I know that battery ZigBee devices can take quite a while to reconnect, but those are not in the picture at this moment.

Seeing as the initial join (before the powercycle) worked without issues, I do not think I have any signal problems. I also have IKEA Trådfri running and it always works fine (stable communication).

Yes it should reconnect automatically (usually after 1-hour or at each state change if its firmware supports push updates), and if it does not then that is usually due to interference or reception issues. Again, suggest reading and following this →

Also recommend that you upgrade to the very latest firmware version of your Zigbee Coordinator adapter, see → (and see links for flashing tools here →

No one from the community seems to have firmware images available for any Develco outlet devices (though you have not written the exact model of your specific product so might find out more if search for a specific model), as if there was then you could have tried upgrading that firmware on your device(s) as well, see example →

PS: Again, also check out Blakadder and Zigbee2MQTT community-maintained device databases that try to collect tips about unique pairing, information, and issues about specific devices, check them out to see if anyone documented tips about your exact model → and | Zigbee2MQTT

I have power cycled the Develco relay multiple times and it never managed to rejoin the network. There is only 2 meters between the coordinator and the relay. And I have the coordinator attached via an extension cable but that changed nothing. I honestly don’t think interference or reception is the problem here.

Regarding firmware, the coordinator uses the next newest firmware (Z-Stack 3.30+ build 20221226) and if there generally isn’t reported rejoin issues with it, I don’t think a new firmware will help. I will look into updating it to be sure, though, but I have a colleague using the same device but via MQTT and rejoins aren’t a problem there.

The Develco Relay (officially named Smart Plug Mini) has the model number SPLZB-131.

Do not be so sure, Zigbee is extremely sensitive to interference, which is why you for example should not use the Zigbee Coordinator in USB 3.0 port or even close to USB 3.0 devices, again, do read:

Only other suggestion is to try performing a full factory reset and re-pair the SPLZB-131 device again, (know that you have already done that but doing that action should normally resolve any device feature discovery issues which show similar symptoms if the device feature discovery failed but still paired).

Next step is to enable debug logging and then open a new issue to Home Assistant core repository to get those debug logs analyzed (as the component for the zha integration is in that repo). See:


If the device is using a ZHA Device Handler (a.k.a. a “quirk”) then could be there a bug in that quirk, or if device is not using a quirk then could be it needs a custom quirk (in ZHA Device Handlers repo), see:

For reference; no one seems to have reported any known issues to these community databases:

PS: Also suggest that you update your original topic of this thread to include the brand and device model in the subject, like for example: “Develco Smart Plug Mini SPLZB-131 connection problem

I have edited the title as suggested.
I have already begun looking at the ZigBee log, but the amount of information is immense and a cursory glance did not reveal the problem. I will try to make a controlled test with logging enabled.

You “other solution” suggestion is the one I have already tried and it works, but I’ll lose the energy consumption for the period the device was offline. Perhaps less of a reset of the relay could be enough, but the best situation is of course to find out why it doesn’t reconnect automatically. If it turns out to be an issue with the relay, I don’t have access to new firmware (if it even exists). But I have used Develco’s older smart plugs (bigger models) and they have always reconnected properly so I don’t expect there is such a bug in the current firmware.

Reg. the USB3 warning: I started out using the coordinator in the USB3 port and without extension coord and communication was fast and reliable. I have since moved it to USB2 and with extension coord, but it changed nothing.

Maybe this: powercycle your coordinator and try to pair the relay again…

I have done that a few times already. :-/ I’ll try to check the debug log. Maybe it gives a clue.

Just noticed another switch had lost connection to the coordinator (the switch blinked, indicating it could not connect to the coordinator). I decided to restart Home Assistant and the switch turned up again. I did not touch the switch itself.

Perhaps there is a bug in ZHA regarding allowing devices to reconnect. That being said, this device has not been power cycled and neither has the coordinator. The switch can see both the coordinator and two other switches, so there is no reason why it should not remain connected.

Anyway, I have now upgraded to the latest home assistant docker image and hope connections will be more stable.

I wanted to give an update on this situation in case anyone finds it. I managed to get hold of an updated firmware with a changelog on which changess were implemented and from that document I could see that my SmartMini Plugs had the very first firmware that was release. I could also see that numerous fixed and changes were implemented since then. I updated the device and stability seems to be much improved. Reconnect happens withing a few seconds (typically 5 seconds after power-up) and stability is generally improved (all devices still online after 2 days, a record).

During this process I discovered that ZHA actually supported firmware updates on this device, despite there is no config option to enable/disable it that I know of. I just enabled all known vendors, configured the OTA folder and put the .zigbee file in the folder. Success. :slight_smile:

I do not know if I am allowed to distribute this firmware, so at this point in time, I wont.

Hi Bernhard, good you found a solution!
You don’t have to share the FW itself but a link to it could help others as well.

Also: even though you have put it in the topic title, please take the time to mark the answer as solution, you do that by selecting the three dots under the post:


Then select the check box:


By doing so this can be useful to other users as well and prevents that someone else steps in and still tries to help you.

I have asked, and I am allowed to share the firmware, but there is nowhere to download it from. So I will have to upload it somewhere…

Follow this guide to add the OTA to the zigbee-OTA repository.

I have connection and also reconnection issues with one of my Develco Smart Plug Mini SPLZB-131 devices. What’s the version or date of the update firmware you got, and any progress making it available?

I completely forgot about publishing the firmwares. I have no connection problems with the latest firmware. I’ll see what I can do.

Edit: It requires nodejs to add firmware files. I don’t really want to install nodejs and need with pull requests just to add firmware files. I can send you the firmware directly, though.


Today I noticed an update for my SPLZB-131 devices through Z2MQTT that’s how I found this post. Couldn’t find a changelog only that SPLZB-131 was replaced by SPLZB-141 (Develco SPLZB-14x Smart Plug Mini 2 Instruction Manual)

If anyone finds anything please please feel free to let us know.


I have the changelog somewhere. Send me PM with an email and I will reply with the document.