[SOLVED] ERROR Uploading YAML via OTA: [Errno 104]

Operating environment/Installation (Hass.io/Docker/pip/etc.)

  • HA on Docker

ESP (ESP32/ESP8266, Board/Sonoff)

  • ESP8266EX (ESP-01)

Affected component

  • ESPHome OTA

Description of problem

  • ERROR Uploading YAML via OTA: [Errno 104] Connection reset by peer
  • Tried two different modules, same result. Tried with Wemos D1, worked fine.

Problem-relevant YAML-configuration entries

  name: esp01_am2320
  platform: ESP8266
  board: esp01_1m

  ssid: ""
  password: ""

  # Enable fallback hotspot (captive portal) in case wifi connection fails
    ssid: "Test Am2320 Fallback Hotspot"
    password: ""


# Enable logging

# Enable Home Assistant API


  sda: 0
  scl: 2
  scan: True
  - platform: am2320
      name: "Living Room Temperature"
      name: "Living Room Humidity"
    update_interval: 10s

Logs (if applicable)

INFO Reading configuration /config/esphome/test_am2320.yaml...
INFO Generating C++ source...
INFO Compiling app...
INFO Running:  platformio run -d /config/esphome/esp01_am2320
Processing esp01_am2320 (board: esp01_1m; framework: arduino; platform: [email protected])
HARDWARE: ESP8266 80MHz, 80KB RAM, 1MB Flash
Dependency Graph
|-- <ESPAsyncTCP-esphome> 1.2.2
|   |-- <ESP8266WiFi> 1.0
|-- <ESP8266WiFi> 1.0
|-- <ESP8266mDNS> 1.2
|   |-- <ESP8266WiFi> 1.0
|-- <ESPAsyncWebServer-esphome> 1.2.6
|   |-- <ESPAsyncTCP-esphome> 1.2.2
|   |   |-- <ESP8266WiFi> 1.0
|   |-- <Hash> 1.0
|   |-- <ESP8266WiFi> 1.0
|-- <Wire> 1.0
|-- <DNSServer> 1.1.1
|   |-- <ESP8266WiFi> 1.0
Compiling /data/esp01_am2320/.pioenvs/esp01_am2320/src/main.cpp.o
Linking /data/esp01_am2320/.pioenvs/esp01_am2320/firmware.elf
Building /data/esp01_am2320/.pioenvs/esp01_am2320/firmware.bin
Retrieving maximum program size /data/esp01_am2320/.pioenvs/esp01_am2320/firmware.elf
Checking size /data/esp01_am2320/.pioenvs/esp01_am2320/firmware.elf
DATA:    [=====     ]  45.0% (used 36888 bytes from 81920 bytes)
PROGRAM: [====      ]  39.8% (used 407556 bytes from 1023984 bytes)
Creating BIN file "/data/esp01_am2320/.pioenvs/esp01_am2320/firmware.bin" using "/data/esp01_am2320/.pioenvs/esp01_am2320/firmware.elf"
========================= [SUCCESS] Took 18.70 seconds =========================
INFO Successfully compiled program.
INFO Resolving IP address of esp01_am2320.local
INFO Address in use when adding to multicast group, it is expected to happen on some systems
INFO  ->
INFO Uploading /data/esp01_am2320/.pioenvs/esp01_am2320/firmware.bin (411712 bytes)
Uploading: [=                                                           ] 2% 
ERROR Error sending data: [Errno 104] Connection reset by peer

Solved: ESP does not have enough space to store OTA file

1 Like

actually if that is the case it should just say that.
I get this error when doing ota on a dual band wifi.
if it is a pure 2.4GHz wifi, it works fine.

i dont think its true. I flashed the exact same file around 25 times allready just tweaking a treshold value. and now all of a sudden it gives this error and cant flash it.

Cheap garbage these esp modules

lmao tried 5 more times just button bashing retry and now it flashes again…