SOLVED: Error while updating from 0.111.4 to 0.112.3

I need some help because I can’t figure this out. I’m trying to update from 0.111.4 to 0.112.3 but the update keeps failing with the following error (supervisor log):

CRITICAL (MainThread) [supervisor.homeassistant] Home assistant update fails -> rollback

I have tried multiple times and can’t seem to figure out what is going wrong. I have tried, in the following order:

  1. Rebooting the raspberry Pi
  2. Removing from the reporter configuration the db_url to mysql so it wouldn’t migrate the big database
  3. Of the custom components that I have installed,
  • eero Mesh WiFi Device Tracker
  • Fast-Hue polling
  • HACS
  • Sonos Player Modes
  • zigbee2mqtt Networkmap

I have disabled Sonos Player Modes and eero Mesh WiFi Device Tracker, just in case they may be causing issues.

  1. I ran the Check Home Assistant configuration and it finished with Configuration check finished - no error found! :)

I don’t know what else to try, does anyone have any idea what would cause this problem?

EDIT 07/06/2020 to add the 4th troubleshooting step

Have you tried using the “Check Home Assistant configuration” add-on? If not it might give you a hint as to what needs to be fixed.

Yes, sorry, I had tried that already and but I forgot to add it to the first post.
It finishes with Configuration check finished - no error found! :)

Looking at your printout I would guess it got to the add-on update. What add-ons are you using? Have you checked the 0.112 release thread for issues others had with the add-ons they had installed that match your installation?

I followed your suggestion and looked through the thread, I found one other person with the same problem but no solution.

This are the addons that I have installed, but I didn’t think these could cause problem with the home assistant core, they don’t really interact with it…


Looking at my log, after the PulseAudio line I see a bunch of add-on updates happen. Your listing doesn’t show any so my guess is that it is having problems updating the first one. So start there. Also I understand that you’re trying to make the update easier but you may be causing more problems for yourself by removing things than trusting that the system update can handle it correctly.

Thank you so much for your help! Do you mind showing me a couple of lines of your update log?
I don’t understand what kind of addons you are talking about and I don’t know in what order they are supposed to be updated.
I’ll also try running the update again with the log set on verbose.

The update to supervisor 230 fixed the problem.