SOLVED ESPHome compile error

Tags: #<Tag:0x00007fc42518b258> #<Tag:0x00007fc42518b140> #<Tag:0x00007fc42518b078>

Hey together, I´m a newbie in Home Assistant. I got myself a Raspberry Pi 4 for Christmas and startet a few weeks ago with ESPHome. I installed Home Assistant Supervised because I also run Boinc and Pi-Hole on my overclocked Pi. After I wrote the script for my ESP32 I discovered that I couldn´t compile the code. It said that there are some libraries missing. I tried to install the missing libraries manual, but it failed. A friend also got a Pi for Christmas and installed Home Assistant directly with the image from the website and he didn´t have any problems. So I sent him my file and he compiled it successfully for me, so there was no problem with my file. A few days later he also want to install Pi-Hole. He did everything as me with one exception: He restored his Home Assistant with a backup. And now his ESPHome can compile!! So I also installed Home Assistant new from the image and configured nothing except ESPHome. Then I backed up only the ESPHome setting. Next I installed Home Assistant Supervised on Raspberry Pi OS 64bit again and started with the restored backup. Now everything works perfect. I write this post because I searched a lot about this problem and found out that this is a common thing with ESPHome on a Supervised install of Home Assistant. Maybe this workaround can help you. Best wishes from Bavaria.