[SOLVED: for local access]A/C app named TFIAC, anyone ever heard of it?

Sadly, there seems to be no difference since my last attempt :frowning:

Yes nothing changed… :frowning: :frowning: :frowning:

With current versions you do not have to install any component, it is part of the system. You just have to add it to your config.yml.

Yes indeed, the A/C is added in config.yml along with my other devices. The problem is not on how it’s added, it’s just that it does not open the a/c. The rest of the functions get through to the a/c with no problem at all.

1 Like

You are totally right. I just checked mine and it is not working fine. I suppose it stopped working with one of the current versions where they changed the air conditioning module.
I will try to debug this but my problem is that my AC is in a room where I normally have a guest and I do not want to beep it while he is inside. I would need some time.
Could you check if the service call to switch on and off is still working?


What do you mean by “does not open the a/c”? You mean that it is not possible to start it?

The a/c does not power on or off through the Hass menu. As long as I activate the air condition unit through infrared or it’s TFIAC App, all the rest of the functions work properly through Hass

with today update, the issue is fixed!
Thank you fredike !

1 Like

That is great!
And with today’s update you mean v0.100, released October 10th, 2019.

I’ve submitted another PR that will add support for SERVICE CLIMATE.TURN_ON and SERVICE CLIMATE.TURN_OFF

1 Like

Works like a charm :smiley:

1 Like

Really nice thread!

Actually, I’m having issue on pairing the app with the A/C wifi module.
I followed the instruction, I reset via the button, I get the CF message three times (it does not remain on ) and just after the first one I start the Start Config but then nothing more.
I’ve disabled the 5GHz network of my router during setup.

Do you have any suggestion?


@woody4165, I have the same issue: I don’t see my AC showing up in the TFIAC app either. Is the app maybe replaced? According the manual of my AC, I have to use the app “Intelligent AC” which is from the same maker as TFIAC. But that app isn’t supported (yet :slight_smile:) by HA I think.

Anyhow: did you find a solution?

Thanks @MMM78

You made my day!

This app, that I didn’t know, is working fine and I need it to operate the AC also from outside home.

I don’t know if this work with HA, but I’ll will check.

I have defined a config to use the AC with Broadlink and Smartir so I can control it also via HA, it’s not the same, but…

It’s good to hear that this app is working for you :slight_smile:, @woody4165!

Next step is to get it working with HA :slight_smile:
But I have no idea yet how to do it (without extra hardware).

Hopefully you are able to get it working :slight_smile:

Hi @pavlo

I’m trying to do same thing with my Daitsu Air conditioner managed via “Intelligent AC” Android App since with TFIAC I’m not able to pair it.
Was paired with this app from the technician who installed the AC, but I changed my phone and was not able to pair it again.

I tried nmap and I get:

sudo nmap -sU --system-dns
Starting Nmap 7.80 ( https://nmap.org ) at 2020-06-22 10:59 UTC
Nmap scan report for
Host is up (0.0049s latency).
Not shown: 998 closed ports
80/udp    open|filtered http
49153/udp open|filtered unknown
MAC Address: xx:xx:xx:xx:xx:xx (HangZhou Gubei Electronics Technology)

Nmap done: 1 IP address (1 host up) scanned in 3.93 seconds

What can I do next?


I do also acquired TCL Air Conditioner which is controlled with “Intelligent AC”. I’m wondering how difficult would that be to handle such integration with the same codebase? I did run the tcpdump through Wireshark but I’m now stuck at unreadable gibberish. I believe the traffic is not encrypted since i can see “$OEM_TCLISO” inside the packet data, but I didn’t find a way to progress with it yet.

[edit] I’ve also unpacked the app via apktool and it seems the assets could be pretty easily reverse-engineered (at least one of the frontends even had source maps intact), but I’m no backend developer so I’m not even sure what to look for on that side. last thing i could check is that on button command UI runs cordova exec with BLNativeBridge bridge

unfortunately i can’t find where the payload is being obsfuscated


Hello, to everyone, also all new TCL air conditioner has to work with “Intelligent AC” now instead TFIAC. Also I cant register and old air conditioner to TFIAC any more… If anyone can find a solution will be great!
Thanks for all of your effort!

Hey, guys!
I’m totaly new to HA. I’ve just bought a TFIAC AC device. Added the needed stuf in configuration.yaml:

  - platform: tfiac

and restarted HA from Server Controls.
My totaly stupid and noob question is: how can I make it visible in Lovelace? Tryed to add a Thermostat card but I can’t find the entity. Please help/guide me in this.
Thank you!


I have a TCL iQool unit and have added tfiac to my configuration.yaml with mixed results.

I have been able to add a thermostat tile and history graph (displaying current and target temperature) to Lovelace.

I can turn off the unit using climate.turn_off

However, all other controls are producing problematic results.

If I try climate.turn_on from developer tools I get:

Failed to call service climate/turn_on. set_state() missing 1 required positional argument: ‘value’

popping up at the bottom of the screen.

Clicking the power icon on the thermostat tile produces a beep, but nothing else. Many other services that I attempt to call in developer tools also produce a beep, but no other change in the unit.

Any thoughts?


I notice something, that may can help:

I can add now to TFIAC devices with the following MAC Address starting with C8:F7:42
C8:F7:42:12:DC:4A [HangZhou Gubei Electronics Technology]
But not devices with address starting from 24:DF:A7, for those I have to use “Intelligent AC”
24:DF:A7:2B:9F:DE [Hangzhou BroadLink Technology]
24:DF:A7:F2:A7:24 [Hangzhou BroadLink Technology]
24:DF:A7:F2:9D:8B [Hangzhou BroadLink Technology]
I dont know from where to start. Can someone help us to control those TCL aircondtioners with HASSIO?