[Solved] Glances on remote machine - Auto-Start and Temperature Sensors don't work

Hey everyone,

Just to, maybe, save someone some time.

I was trying to import the temperature sensors of a remote machine to my HA through the Glances Integration.

Everything was going according to the documentation except of two things, the auto-start instructions didnt work and, after i figured that out, i could see all the data but no temperatures.

So, about auto-starting, the documentation refers you to this link, where for my case, i had to change ExecStart=/usr/local/bin/glances -w to ExecStart=/usr/bin/glances -w and that fixed it.

About the temperatures, turns out that glances start their webui / api service with the Sensors plug in disabled. I found here the solution to enable it:

I edited /etc/glances/glances.conf to enable the plugin:

# This plugin is disable by default because on some system, the PsUtil
# consume a lot of CPU to grab the stats...

Now both the webUI and home assistant get information about the temperature sensors.

Hope this helps someone :tired_face:

I don’t know how to mark the OP as solved, so I’m marking this, for tidiness.