[SOLVED] Google Assistant and Switch

Hi All,

Quick one; I have a switch in HA to turn on and off my computer; works without issue. I am trying to get google assistant to recognise the switch so I can use it, however, whenever I ask, it just fails with either an error saying that light doesn’t exist or just general error.

I enabled Google integration via the automatic method and I checked that the switch is exposed which I’ve checked by going to Settings → Home Assistant Cloud → Google Assistant → Manage Entities and the switch is in the exposed category with a green tick.

Any advice?

I’ve had this a couple of times, in Home Assistant, go to the entities and click on the tick, set it to do not expose, then in the top right hand corner click the 3 dots and click sync entities, then find the entity again and change the tick to expose entity, then sync them again, this worked for me, it’s like giving it a kick.

1 Like

Worked like a charm, weird bug, hope it gets fixed in the future but thanks for fix!