[Solved] Govee WiFi Thermometer Hygrometer H5179 Intergration Support

I would like to know if there is a way to get this sensor into HA to allow me to control my tuya based smartplug for my dehumidifier that makes actual sense.

I have it linked to the Govee app but I don’t see a way to find the mac address to use the as per the post here: Govee H5179 integration support - #12 by thaddicus and this one here is even more confusing at this time since it’s not telling me how exactly they are pulling the data since I can’t see instructions on what to do with the MQTT code: Using the Govee Bluetooth Thermometer with Home Assistant (Python and MQTT) - Austin's Nerdy Things

My instance of HA is being ran on a virtualbox VM that boots up in headless mode on my nuc and I do have usb passthrough, it also detected a BT adapter when I passed through the Intel USB filter to the VM after the recent windows 11 updated that enabled BT LE support.

I have all the automation ready to go I just need a way to actually get the sensor input into HA. If this is near impossible to do at this time then please recommend me a better alternative to one that can work out of the box with HA.

You can use the Aqara sensors in HA pretty easily using the ZHA integration except that you will need a zigbee controller (USB dongle). Which isn’t necessarily a bad thing since you can then start using all the other myriad zigbee devices in HA as well.

I’ll have to look into what is the recommended z-wave and zigbee antenna’s to setup with my install, I have a hub for tuya based devices that has BT built in but since I have all my plugs already setup via the cloud API for control before I got it I will have to play with that to see what I can do with it (trying to keep as much local as I can where possible so that the only time they access the external service is for syncs for key updates or weather services).

I need to see what is available when it comes to that brand here in Australia, the generic sensor I got before this govee one showed up in HA but it was never updating the sensor data even after a full 48-72hs -_-.

Worse case I will have to see what is the recommended smart dehumidifier that works with HA so I can turn it off and on based on the humidity in my bathroom.

edit: forgot to mention, yes I have tried the Govee Bluetooth integration that lists it as supported but it comes up with the error that no devices are detected (I’m not sure if the BT integration is not working right or if I should just get another BT adapter to test with just to sanity check it)

Quick update.

I bought a Targus USB BT 4.0 adapter on the way home today; which comes up as Kogan 3.0 when plugged into the host NuC, and I was able to instantly import and connect both the switchbot I am using for the HDMI switch behind my main monitor and the Govee H5179 Sensor instantly soon as it was plugged into the USB 3.0 port on my hub I have attached to the NuC that I have mounted on the side of my homelab cabinet.


I will leave this thread up for those confused why somethings are not showing until you get a dedicated USB antenna/adapter and to make sure its installed in the correct port as well as I tested it in the USB 2.0 port on the hub to see if it would show which it did not (might be due to the fact I have the VM set to 3.0 mode for virtual usb ports as well).

1 Like

If anyone finds a way to add via WiFi :confused:

I’m with you, my H5179 is too far for Bluetooth, I got a Wi-Fi model that reason…

I have got the same model H5179, however, I’m unable to read the temperature from HA using WIFI, it is connected via Bluetooth. What integration are you using WIFI or bluetooth ?

same here, not sure why cant HASS work with H5179 with wifi instead of BT…can the stats for 5179 be retrieved from Govee API?

Also looking for a solution for this device…have a computer with bluetooth right by it but Govee desktop app not finding it.

I solved this, but had to use ESP32 Bluetooth proxy, then HA discovered the Govee devices…but you have to have the ESP32 proxy withing BT range, still doesnt use wifi

I believe I have this solved with WiFi alone!

While configurating another device on my network, I set up MQTT. After that was set up and my other device was working, my two Govee H5179 devices just showed up in Home Assistant! :smiley:

Hey Fran, I have the same problem how can I register the Govee Hydrometer to the Mosquito Broker? Thanks in advanced

I would also like to know how you got it to appear in MQTT. I refreshed and restarted MQTT and HA and it doesn’t show up.

Hmm. I really don’t think I did anything to get the devices to register with MQTT. I simply followed the instructions in that page I linked, which was essentially (1) install Mosquito MQTT addon, and then (2) install the MQTT service. After that, I just noticed the Govee devices automagically show up.

I’m new to Home Assistant, but totally willing to help y’all figure this out! I just don’t know the best way to be helpful :sweat_smile::sweat_smile:

How is your MQTT Broker configured? Is it all left as default including ports? I have a couple H5179 as well which sadly are not appearing automatically as yours seemed to. If you can, I think sending the config of your broker would be helpful (obviously excluding the authentication section).

how do you get it working over wifi? all my out builds are far away from my server and run on Ethernet and wifi

Mosquitto MQTT Broker:

logins: []
require_certificate: false
certfile: fullchain.pem
keyfile: privkey.pem
  active: false
  folder: mosquitto

For the network section:

Normal MQTT: 1883/tcp
MQTT over WebSocket: 1884/tcp
Normal MQTT with SSL: 8883/tcp
MQTT over WebSocket with SSL: 8884/tcp

So it seems to all be default? Where in HA did you start seeing the H5179 devices automatically added?

Did you previously set up the wifi thermometer in the Govee app or change any settings there?

@Aaeeschylus Yeah, I really didn’t muck with any of the settings. I saw the devices pop up under Settings → Devices & Services → MQTT → Devices.

@branchmispredictor I did previously set up the Govee Hygrometer in the Govee app; in fact, they’re still configured. I didn’t reset them or anything.

One thing of note is that I do have the Govee integration installed from HACS, however this is just for a few of the Govee smart plugs that I own. The hygrometer doesn’t come up as devices under the govee service, just the MQTT service.