SOLVED: GRAFANA: How do I add the plugin: natel-discrete-panel plugin

I’ve set up the Grafana Add-On made by @frenck It’s really nice to have a good grafing engine like that, and with an easy to add add-on it’s a great complement to HA.

I’ve set up the very nice unifi-poller here, wow, a lot of information is pulled from the controller.
I’ve gotten most of the plugins added, but one is acting up, the ‘natel-discrete-panel’. It’s used on the premade dashboard clients-insight .
I can’t see it in the plugin overview in the add-on, but I was told that I could just add an environment variable like:


So I added this to the config:

    value: natel-discrete-panel

And I can see it being set in the log, but I still don’t see it being loaded.
Any ideas about how to get that loaded?

I install my plugins differently.

  - pluginNameGoesHere
1 Like

Darned, that worked perfectly, I wonder what I did wrong the first time I tried that, I might have misspelled the plugin, but hey, it’s working! Thankyou!

1 Like

For me natel-discrete-panel is was not showing up in panel list because it is not signed and grafana does not load it even if installed ok.
The solution I found was to add a setting in plugin configuration to allow it unsigned.
Sorry for reviving such an old thread but I hope it helps others.

  - natel-discrete-panel
    value: natel-discrete-panel