[solved] HA is unable to find Velux Active / KIX 300, but homekit_python is

Tags: #<Tag:0x00007f7396e99bf0>

Case: Velux Active with paired Somfy IO devices.

This morning i tried setting it up in HA; but i couldn’t pair it. Going to Configuration > Integrations > Add integration all i could find is ‘homekit accesory’ which i can’t find on the website. I was actually looking for the Homekit Controller integration but maybe it changed names.

So first i tried to setup the integration; no devices found which can be paired.

Then i read the instructions

For IP accessories, Home Assistant can only find devices that are already on the same network as your device. If an accessory is Wi-Fi based and has no user interface for joining it to your Wi-Fi network, you will need an Apple HomeKit controller device (an iPhone or iPad). You should pair it with the controller and then remove the pairing in the UI (but do not reset the accessory itself). This will leave the accessory on your Wi-Fi network but in an unpaired state, and then Home Assistant can find it.

Since the Velux Active is a WiFi device, and has no UI to configure pairing, i did the above (paired it with the Home app on my wife’s iPad, removed the HUB) without luck. Still no devices found which can be paired.

Then i booted my works laptop (mac) installed Homekit Python and tried discovering devices. It nicely shows the Velux on the commandline, so it IS discoverable:

Name: VELUX gateway._hap._tcp.local.
Url: http_impl://192.168.1.186:5001
Configuration number (c#): 7
Feature Flags (ff): Supports HAP Pairing (Flag: 1)
Device ID (id): 59:XX:XX:XX:XX:XX
Model Name (md): VELUX Gateway
Protocol Version (pv): 1.1
State Number (s#): 1
Status Flags (sf): Accessory has not been paired with any controllers. (Flag: 1)
Category Identifier (ci): Bridge (Id: 2)

Bottom line is, what am i doing wrong?
I am running HA via docker (homeassistant/home-assistant:latest) - which translates in my case to version 0.108.3

Solution:
I had my Home-Assistant running only on the Reverse proxy network only (Traefik) which allowed my to perfectly connect and use HA for all my current use-cases. What it did was that it only gave the docker container a local 172.x.x.x address. What was confusing me before i found out was that HA did find my Chromecast devices (but in contrast didn’t show them in the Lovelace UI).

After adding my bridge network to the compose file and assigning a dedicated IP on my 192.x range; rebooting HA, it immediately showed that it found a couple of new devices (5 in total) amongst which was the Velux gateway. Strange thing was that the Chromecast devices also appeared on the Lovelace UI all of a sudden.

Anyway; hope my rant helps somebody :slight_smile:

Thank you for sharing the result. I will most likely run into the same issue, when I go get Velux active.
Can you share with me what is possible with the Velux active connected to HA? I guess you can open and close the windows, but do you get the data from the klima sensor aswell? And do you find it a stable solution?

I’m thinking of replacing the Velux remote KLR200 with an iPad with HA, where I then control my windows. But only if it is stable option of course :slight_smile:

Hi I have your same problem, but I did not understand well how you did it. could you post me a practical example. I am a beginner and as a test I am trying HA virtualized in virtualbox. I launched HA the first time and it automatically recognized the VELUX gateway, then I made other messes in HA and I decided to start again.
At this point with a new virtualization I can no longer see the VELUX gateway. Thanks in advance

there is another solution. You might need to reset your Velux gateway to active homekit connection. Here is how to do so:

"When resetting your gateway’s HomeKit link, delete:

  • The Wi-Fi connection between the gateway and your router.
  • The HomeKit link of your gateway.

The connection to your VELUX products, sensor and departure switch remains unchanged.
Follow the steps below to perform a HomeKit reset:

  • Press and hold the button marked with the gear icon.
  • When you see the LED blink red, release the button and quickly press the button again to confirm the reset.
  • The gateway is now reset and restarts automatically.
  • When the LED flashes white, your gateway is ready for a new HomeKit link.
  • Open your Home app and add the gateway as a new accessory in HomeKit. "