[Solved] Hass.io on raspbian lite buster


I’m trying to install hass.io on a raspberry pi 3 running a clean raspbian lite buster install.

I followed all instructions here (https://www.home-assistant.io/hassio/installation/) for the generic linux install.

To get docker-ce I added this file /etc/apt/sources.list.d/docker.list with the following inside:

deb [arch=armhf] https://download.docker.com/linux/raspbian buster nightly
deb [arch=armhf] https://download.docker.com/linux/raspbian stretch stable

Reason to also add the strech repo is that the buster repo not yet works for it self (missing packages).

But now when I try to install hass.io on my system with docker-ce I get the following error

Executing as root: curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s -- -m raspberrypi3

[Info] Install supervisor Docker container
could not get decompression stream: fork/exec /usr/bin/unpigz: no such file or directory

Any ideas how to proceed?

But did you actually install docker-ce?

yes (post must be at least 10 characters)

Did you install the 10 or so requirements before running the install script? (after docker)?

Actually the required packages are:

apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat

and should be installed before docker-ce

1 Like

@DavidFW1960 @picohassiotts

I did excactly what’s written in the install manual and installed all the needed packages before docker

Found it. The missing package was pigz. Now it works