[SOLVED] Hassio Configurator panel_iframe issue

I’m struggling to have the Configurator panel_iframe working properly on Hassio with HTTPS.

After one of the latest update of Configurator component, the panel_iframe behaves in a weird manner due to the fact that now the Configurator component has no more a dedicated ip/port connector, but it has been embedded in Hassio.

My configuration.yaml, that worked up to the latest Configurator component update is:

        title: 'Configurator'
        icon: 'mdi:wrench'
        url: !secret https_configurator

The https_configurator points to: https://HOSTNAME:PORT/hassio/ingress/core_configurator (where, HOSTNAME and PORT are from DuckDNS)

The result of this configuration is somehow weird, since in the html iframe it is loaded recursively the whole Lovelace UI:

Any suggestion to avoid this and have back the correct visualization?

Many thanks,

see the post above for the release notes on ingress (read them carefully) and if you want to use an iframe before 0.92.0 see the second link of that post.

1 Like

Thanks for the reply.

For the sake of simplicity, I’ll write what I did: since the new version of Configurator component uses Ingress, to make the panel_iframe work again as expected, it is necessary to set the port in the add-on configuration section (Hass.io >>> Dashboard >>> Configurator >>> Network section). In my case, the internal port is 3218. I saved and restarted the add-on:

I also slightly changed my configuration.yaml:

        title: 'Configurator'
        icon: 'mdi:wrench'
        url: !secret http_configurator

The http_configurator points to: http://HOSTNAME:PORT (where, HOSTNAME is from DuckDNS and PORT is the one I configured on my router to point internally on the RPi ip address on port 3218)

I tried to use HTTPS, pointing the browser directly to https://HOSTNAME:PORT, but it does not work.

The problem I have now is that it works on HTTP but not in HTTPS, as it was before.

I miss what to do to make the HTTPS connection work again.


If you want the menu now. replace your iframe section with this. I got it from someone else here.

  - name: hassio-main
    sidebar_title: Configurator
    sidebar_icon: mdi:wrench
    js_url: /api/hassio/app/entrypoint.js
    url_path: configurator
    embed_iframe: true
    require_admin: true
      ingress: "core_configurator"

@ bosborne: Yes, this definitively solved in the right way the issue.