(solved) Help, mqtt binary sensor disappeared after update


#1

since a few years I use the mqtt binary sensor for my motion sensors 433mhz. Works good. But since last update of hass, all these motion sensors and the 433mhz temp. sensors disappeared.

Strange thing is, the mqtt switches still work. But they are more or less the same as the sensors. What went wrong?

binary_sensor 1:
  platform: mqtt
  name: "beweging-overloop"
  state_topic: "ninjaCape/input/#"
  payload_on: "101111100100010011011111"
  payload_off: "000000"
  device_class: motion

switch 1:
  platform: mqtt
  name: "avl"
  state_topic: "ninjaCape/input/110"
  command_topic: "ninjaCape/output/11"
  payload_on: "000000011100110000001001"
  payload_off: "000000011100110000000100"
  optimistic: true
  qos: 0
  retain: true

sensor 11:
  platform: mqtt
  state_topic: "ninjaCape/input/310101"
  name: "temperatuur sensor-boven"
  qos: 0
  unit_of_measurement: "°C"

#2

Check your developer tools states menu. The - in your sensor names have been replaced with _ as per the very first sentance of the 0.85 release notes.


#3

Thank you. First thing I am going to try tomorrow.


#4

It worked! I missed this breaking change…