SOLVED- Help- unable to restore a snapshot

My Dexcom integration sometime yesterday- stopped getting data from Dexcom.

History- I upgraded to 2022.7.1 that morning and everything appeared to be working. Several hours later my Dexcom displays stopped receiving data. I tried to roll back to 2022.7.0 and nothing happened. No error messages, no log entries, nothing.

I tried to go forward to 2022.7.2 and got this error:

…update blocked from execution, no host internet connection

Next I tried to SSH (Putty) into my host and got:

“No supported authentication methods available (server sent: publickey, keyboard-interactive)”

I tried rebooting the host- no change.

Weirder yet, HA is still working otherwise. I can even use the terminal add-on to log on to HAOS and I can ping external servers (google, for example).

Any help would be appreciated. Not getting my Glucose data is bad enough, but I can’t even roll back to a known working snapshot.

I am running HAOS on an Intel NUC.
Home Assistant 2022.7.1
Supervisor 2022.07.0
Operating System 8.2
Frontend 20220707.0 - latest

Solved- Reboot the router.