[SOLVED] Help with Foscam F19803PV3

I’ve got the Foscam F19803PV3 camera and I’ve set it up in Hass.io. For the most part it works, but there’s one thing that doesn’t. In Lovelace, it shows the image in a picture-entity card and it updates every few seconds, but when I click on it, I get a small window with a play button and a waiting circle that never ends. Pushing the play button does nothing.

Here is my configuration in the camera section of configuration.yaml:

  - platform: foscam
    ip: 192.168.X.X
    port: 20081
    username: xxxx
    password: !secret fpcamera_password
    name: Front Porch Camera

I should mention up front that my security cameras are on a different wireless router that is connected into my main network to reduce traffic strain. So, I’m using NAT on the 2nd router to forward port 88 of the camera to port 20081 on the main network. This doesn’t seem to cause any issues for the actual Foscam plugin running in IE from a browser on my main network. It is able to stream the camera with no issues using that forwarded address.

My other generic cameras just bring up a larger image of the one in the lovelace page when I click on them.

This is my lovelace configuration for the Foscam:

      - aspect-ratio: 60%
        entity: camera.front_porch_camera
          action: none
        image: 'https://www.home-assistant.io/images/merchandise/shirt-frontpage.png'
        tap-action: more-info
        type: picture-entity
        camera-view: live

I just added the camera-view line today after reading some other forum posts, but it didn’t make any difference. I do have stream enabled in my configuration.yaml.

Just wondering if anyone else has this camera and it’s working like it’s supposed to?

Bumping since there’s been no response in the last couple months. I’m running hassio 0.105.4 now and still have the same issue with the Foscam camera

Disable stream: in your config, works better then

I removed it from configuration.yaml but it didn’t seem to make a difference. Same issue.

it seems i am using the “generic” component for my foscams cameras… working well here

  - platform: generic
    name: Bureau
    still_image_url: !secret bureau_still_image_url
    stream_source: !secret bureau_stream_source
    verify_ssl: false

and i am using the sream source and img url exposed from my synology surveillance system
or you can use motioneye
or use the direct stream paths from your foscam

Ok, I fixed it. Turns out I did not have the rtsp port forwarded through the second router. So I was only getting snapshots but the streaming has to be done through rtsp.