[Solved] Home Assistant Down

After successfully migrating over from Wink, my Home Assistant is down. Not sure how to connect to my pi either.
I actually recently posted the following in the Reddit sub:

Successfully moved my whole smart home from Wink to Home Assistant (cloud with Alexa) without nabu casa. On my wink I had myQ and Alexa linked, and loved the remote feature. Home Assistant wasn’t easy but it also wasn’t impossible. I’m also fairly new to r/HomeAutomation so I hope this post is in the right place to help a now formal Wink user who didn’t want to pay the $5 a month.

My Journey started the day Wink announced they would start a subscription start. I bought a Raspberry Pi 4 and Nortek stick for zwave and zigbee.

CanaKit Raspberry Pi 4 4GB Starter Kit - 4GB RAM

GoControl CECOMINOD016164 HUSBZB-1 USB Hub

Coming from a super noob, I had no idea what to do and I plug my monitor, keyboard, and mouse into my pi to download hass.io. This didn’t work and then I tried the imaging with etcher. For a few days I was stuck here because I didn’t know that using a mac you need to format the SD Card and clean the disk to FAT32. My next issue was I was still using the pi on the wifi (still an issue). I monitor the hass.io installation from my monitor connected to my pi and never finished. For days it was stick starting and stoping something because of “wlan0: link is not ready”. I ended up pluging an ethernet directly in my pi just guessing that it worked and decided to see if homeassistant.local:8123 would load. And it did! For my initial setup I followed this youtube video: Beginner’s guide to Home Assistant

This video also has a previous version to that could be helpful as well. I think a confusing thing I ran into was how normal he makes the whole process sound. I ended trying to use the unified addon which is wrong. His process is good (not) for setting the remote access without nabu casa. I used the DuckDns addon and ran into trouble with this as well. I had my cloud working but not SSL cert, ended up being a config issue with the “-”.

Adding all my devices were easy except for my locks. The documentation on Home Assistant is what I found to be most helpful this. I still am not quite sure what some of the statuses mean on my locks however.

Kwikset 98880-004 SmartCode 888 Smart Lock

These are good locks for the price but just are to add to any smart system, I had trouble with Wink and just about the same amount with HA so keep that expectation. However, I was nice that I was able to configure user codes within HA (can’t this on Wink). Another stab at Wink was after the connection to Alexa on HA I was able to lock/unlock and do garage functions as well.

Connecting HA to Alexa with HA cloud is super hard but Home Assistant Documentation makes it actually really easy. Except theres one flaw, account linking requires you use port 443. Port forwarding on remote access makes it so you port forward 443 to 8123, which means you cannot link HA with Alexa. My work around for this was simply changing the default port in the config.yaml.

Boom! I did it! I moved over the Sengled Smart LEDs , my locks, (Dome) Water Shut-Off Valve, leakSMART Water Sensor, and reintegrated Alexa and myQ plus Ring. Yes it was a bit of work but now I will never have to worry about paying $5 a month. Also it was a little fun and now I have more control. I used Yonomi to control my locks and garage with Wink before this.

After I posted this I forgot about my GE zwave switch that was still connected to Wink. I couldn’t get it to connect my Home Assistant so I decided to turn my Wink back on and remove it from their app. A bunch of my devices reconnected to my Wink, so I removed those again in addition to the switch. I unplugged my Wink then restarted my Home Assistant but it never booted back up. So I turned off power to my pi, waited a bit, then tried again without any success. My pi is on but I still cannot reach it on my duckdns domain and I was never able to connect to from my mac, so I don’t know how to diagnose the problem. Has anyone else had a similar issue? Not sure what to do

Unless you installed the ssh Add-On, I know of no way to connect to the RPI over the network.

I believe your only recourse is to connect a monitor and keyboard to the RPI and login directly to the command-console. I believe the username is homeassistant root and there’s no password; you have the ability to explore the system and hopefully correct the problem. If you get no login prompt then something went terribly wrong and your remaining option is to reflash the SD card and start over again.

If there is no login prompt is it possible to restore from any of the snapshots I have?

Also I do have the ssh Add-On. So how would I go about that route?

If you have the SSH Add-on then you can use an ssh client to connect to the RPI. If you are using a MacOS or Linux machine then you have an ssh client available in the OS. If you are using Windows then you can get a free ssh client called PuTTY.

Once you are connected, you can use the command ha. It has many options including the ability to restore a snapshot.

How do you get connected from MacOS? I only used the SSH add on within HA gui.

Open the Terminal app in MacOS then enter:

ssh root@YourServerName


ssh root@YourServerIPaddress


ssh [email protected]
ssh [email protected]

Ha! I just tried it and was denied connection to my own functional server! :man_facepalming:

I believe the username root with no password approach is just for direct console access.

Revised instruction for connection via the SSH Add-On:

  • Use the username and password you specified when you configured the SSH Add-On.

ssh [email protected] returns connection refused
ssh root@MyServerIPaddress returns Operation timed out

just connected a monitor to my pi and the display’s tail is stuck on forward blocking state in port 7?

See my revised instructions above. Use the username and password you specified when you configured the SSH Add-On.

If you are already connected to the command console then we can skip over the remote-access instructions.

If you don’t see a command prompt consisting of a blinking cursor next to an arrow and tilde, then it must be stuck on something. Try issuing a Ctrl-C in the hope it aborts whatever it is in the middle of doing.

Connection Refused. I think this has to do with the fact HA hasn’t finished booting up. Do you know anything about the log I mentioned?

hassio: port 7(vethbff74fb) entered blocking state
hassio: port 7(vethbff74fb) entered forwarding state

Sorry, no, I know nothing about that message.

If the direct console offers no access to the system then I don’t know what else can be done (other than a complete re-install). Perhaps wait a day or so to allow someone more knowledgeable than me to offer advice (because a re-install means a total loss of everything you had unless you saved a snapshot to another machine).

I moved the ethernet port from port 0 to port 1 on my router and now everything works. Very strange. Time to save a snapshot to another machine !

Glad to hear it works now.

If you plug something else to port 0 does it also fail? In other words, is that port faulty or was changing the port just a happy coincidence.

Happy coincidence, my guess was the internet/ether needed to be reset?