(SOLVED) Homeassitant on OdroidXU4 / emmc

(first sorry for my english)

Hi, i can’t run Homeassitant on my odroid XU4 :frowning:

dit someone realy test it ? and it’s working ?

i try to install this version
github.com/home-assistant/operating-system/releases/download/5.10/hassos_odroid-xu4-5.10.img.xz
from this page : www.home-assistant.io/hassio/installation/

when i burn it to my emmc ( balena etcher os osx ), Odroid can’t boot ( blue fixed led ) .
I have tried to SD , it launch, but stay on this page

( tried to wait 8h … it’s writed 20 minutes )

it’s not a default of my emmc or odroid board, if i’ll try to install a debian version ( from de.eu.odroid.in/ubuntu_20.04lts/XU3_XU4_MC1_HC1_HC2/ubuntu-20.04-5.4-mate-odroid-xu4-20210113.img.xz ) , debian run good
i have tried to install hass on debian manualy, but no supervisor option … lol

did someone complete installation on the odroid emmc ?

finaly i successfuly install HomeAssistant with supervisor .

this is my procedure :
install a fresh ubuntu 20.04 on the emmc
(i use the minimal one , but it work with the mate version )
https://wiki.odroid.com/getting_started/os_installation_guide#tab__odroid-xu4
burned from my osx with balena etcher on the emmc with emmc to microsd adaptor and microSD to usb .

once burned, boot to the emmc ( red light on and blue one like an earthbeat )
SSH : root/odroid ( please change it :stuck_out_tongue: )
apt update
apt -y upgrade
apt-get install -y software-properties-common apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat docker docker.io containerd runc
systemctl disable ModemManager
systemctl stop ModemManager
curl -Lo installer.sh https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh
bash installer.sh --machine odroid-xu ( you need perhaps to launch 2 time this script , please reboot if needed )

and after some minutes, Homeassistant is OK to port 8123 :slight_smile: enjoy

1 Like