[SOLVED] How to get node-red-dashboard on a HA dashboard tab?

I want to use a Node-Red-Dashboard on a HA Dashboard tab like seen here in this sprinker system video

Being the first time I have attempted to use the node-red-dashboard I am a couple of hours in an stuck at the point where;

  1. It appears as though I that the whole tab in HA dashboard will be a node red dashboard instead of adding individual entities using an entity card like I would normally add.
  2. I thought for abit I was adding it as a iFrame but iFrame as just for the HA side bar. So I think I would add it as a webpage card?
  3. I cannot seem to access the Node Red Dashboard customized view I am building it appears I access via my homeassistant url 192.168.0.245:1880/ui (as seen in ‘the hook up’ vid here.
  4. When I access this port on http I get 400 error bad request, if I use https I get the unsafe page load in chrome and it is trying to load my duckdns certifcate (as below) if I proceed it asks me to login I’ve tried the node red credentials and home assistant credentials neither work
  5. I read that when ingress is enabled (eg node red) as long as the port number is set eg 1880 then direct access is allowed however this does not seem to be the case.

My Node Red config

credential_secret: '!secret node_red_credential_password'
dark_mode: false
http_node:
  username: admin123
  password: '!secret node_red_password'
http_static:
  username: admin123
  password: '!secret node_red_password'
ssl: true
certfile: fullchain.pem
keyfile: privkey.pem
require_ssl: true
system_packages: []
npm_packages: []
init_commands: []

Face palm :woman_facepalming: my VPN was running in the background.

I was able to access via myipaddress:1880/endpoint/ui I found this address by going into Node Red selecting dashboard from the right menu and the pop out icon.

I then used a website card in the lovelace dashboard and entered this address and it now shows.

2 Likes

I discovered after trying on my mobile phone that you have to authorise each device when connecting to the Node Red Dashboard for the first time so I will document the full proceedure.

  1. Make sure Node Red settings have the username and password fields populated with something unique as you will need to enter these to authorise the devices when connecting for the first time.
  2. Make sure you restart the node red addon after making changes.

Example of my node red configuration:

credential_secret: '!secret node_red_credential_password'
dark_mode: false
http_node:
  username: uniqueNodeRedUsername
  password: uniqueNodeRedPassword
http_static:
  username: uniqueNodeRedUsername
  password: uniqueNodeRedPassword
ssl: true
certfile: fullchain.pem
keyfile: privkey.pem
require_ssl: true
system_packages: []
npm_packages: []
  1. In Node Red on the right slide out menu navigate to Dashboard and then click on the pop out window which will open https://yourhomeassistantip:1880/endpoint/ui/ and ask for username and password at which point you enter the username and password you set in the node red configuration.
  2. You should now be looking at the Node Red Dashboard with your node-red-dashboard nodes you have added to your flow.
  3. If this is successful you can now go to lovelace an add a webpage card and enter the address https://yourhomeassistantip:1880/endpoint/ui/ and you should see your Node red dashboard in the preview.
  4. You need to do step 2 on every device you want to see the Node Red dashboard.
  5. If you are connecting remotely (eg you are not on the same local network as home assistant) to home assistant you need to port forward 1880 to your home assistant IP.
1 Like

Been having loads of trouble getting my node red sequences into HA and this is the first route that’s actually worked.

Tried with hass-node-red but could get node red to show in the HA UI under Integrations after installing with Hacs.

Also tried, creating an entity through the /configuration.yaml but struggled here too, not even sure if that would have worked anyway (pretty new to HA).

Cool glad to help.

The is a bug which I reported to one of the team already. If you use the HA app from the app store on your phone you CANNOT authorise the app with nodered as done in step 2 above because when you click on the pop out it takes you to your phone’s browser to sign in to node red so your browser gets authorised not the app and therefore the node red dashboard cannot load on your phone app. The only work around I can think off is to not use the HA app from app store but save the shortcut from the mobile webpage version to your phone’s homescreen.

I faced same problem and created addon that proxies any port to ingress panel.


After manual installation (sorry, dont have time to publish it) you need to specify port (1880 for node-red) and path (endpoint/ui/ for node-red-dashboard)
You are welcome :slight_smile:
1 Like

Hello,
I am having the issue of not being able to use the node red dashboard via nuba casa / cloud.
I have tried to install your solution, and I can now see it in the add on store as a local add on.
But when I try to install (by clicking the install button) I get this error…

Failed to install addon

The command ‘/bin/bash -o pipefail -c apk add --no-cache --virtual .build-dependencies g++=9.3.0-r2 gcc=9.3.0-r2 libc-dev=0.7.2-r3 linux-headers=5.4.5-r1 make=4.3-r0 && apk add --no-cache git=2.26.2-r0 lua-resty-http=0.15-r0 nginx-mod-http-lua=1.18.0-r0 nginx=1.18.0-r0 openssh-client=8.3_p1-r0 patch=2.7.6-r6 && apk del --no-cache --purge .build-dependencies && rm -fr /tmp/* /etc/nginx’ returned a non-zero code: 3

I previously copied all the files to the addons folder as you instruct, and in the config.json file I added:-
“options”: {
“port”: “1880”,
“path”: “/endpoint/ui”

I notice there is a homeassistant entry which currently says :-
“homeassistant”: “0.92.0b2”,
Do I need to change this to match the version of homeassistant I have installed?

Any help you can offer would be gratefully received

Deaks :- :smiley:

1 Like

I successfully displayed the Blynk temperature into Home Assistant Guage Card using Node Red Home Assistant Entity node…

I took what you did cleaned it, updated all the deps and got it to work -

Just add it as a custom repository and install, no config needed, no custom ssl certificates and no port openings

1 Like

Hi, I’ve the same problem of the author, and I’m quite new about HOME ASSISTANT, you can explain it to me more precisely?

thanks in advance!

Alan

@regevbr


this is my result when I’ve got installed the Add-on, what can I do to fix it?

Alan

@alanmasu sorry I don’t know… this is an error from the docker build phase… Can you extract more logs?

I got same error.

OS 6.6
Core-2021.11.5

Here is logs

21-12-05 16:24:19 INFO (SyncWorker_2) [supervisor.docker.addon] Starting build for a2b947f4/amd64-addon-node-red-dashboard:dev7
21-12-05 16:24:46 ERROR (SyncWorker_2) [supervisor.docker.addon] Can't build a2b947f4/amd64-addon-node-red-dashboard:dev7: The command '/bin/bash -o pipefail -c apk add --no-cache --virtual .build-dependencies         g++=10.3.1_git20210424-r2         gcc=10.3.1_git20210424-r2         libc-dev=0.7.2-r3         linux-headers=5.10.41-r0         make=4.3-r0         && apk add --no-cache         nginx=1.20.1-r3         openssh-client=8.6_p1-r3         patch=2.7.6-r7         python3=3.9.5-r1         && echo -e "StrictHostKeyChecking no" >> /etc/ssh/ssh_config         && apk del --no-cache --purge .build-dependencies     && rm -fr         /tmp/*         /etc/nginx' returned a non-zero code: 2
21-12-05 16:24:46 ERROR (SyncWorker_2) [supervisor.docker.addon] Build log: 
Step 1/17 : ARG BUILD_FROM=ghcr.io/hassio-addons/base/amd64:10.1.0
Step 2/17 : FROM ${BUILD_FROM}
 ---> 3c5129a80828
Step 3/17 : WORKDIR /opt
 ---> Using cache
 ---> dd3e0319aa33
Step 4/17 : SHELL ["/bin/bash", "-o", "pipefail", "-c"]
 ---> Using cache
 ---> 99a90873a7b2
Step 5/17 : RUN     apk add --no-cache --virtual .build-dependencies         g++=10.3.1_git20210424-r2         gcc=10.3.1_git20210424-r2         libc-dev=0.7.2-r3         linux-headers=5.10.41-r0         make=4.3-r0         && apk add --no-cache         nginx=1.20.1-r3         openssh-client=8.6_p1-r3         patch=2.7.6-r7         python3=3.9.5-r1         && echo -e "StrictHostKeyChecking no" >> /etc/ssh/ssh_config         && apk del --no-cache --purge .build-dependencies     && rm -fr         /tmp/*         /etc/nginx
 ---> Running in ad00bd36b220
fetch https://dl-cdn.alpinelinux.org/alpine/v3.14/main/x86_64/APKINDEX.tar.gz
fetch https://dl-cdn.alpinelinux.org/alpine/v3.14/community/x86_64/APKINDEX.tar.gz
(1/17) Installing libgcc (10.3.1_git20210424-r2)
(2/17) Installing libstdc++ (10.3.1_git20210424-r2)
(3/17) Installing binutils (2.35.2-r2)
(4/17) Installing libgomp (10.3.1_git20210424-r2)
(5/17) Installing libatomic (10.3.1_git20210424-r2)
(6/17) Installing libgphobos (10.3.1_git20210424-r2)
(7/17) Installing gmp (6.2.1-r0)
(8/17) Installing isl22 (0.22-r0)
(9/17) Installing mpfr4 (4.1.0-r0)
(10/17) Installing mpc1 (1.2.1-r0)
(11/17) Installing gcc (10.3.1_git20210424-r2)
(12/17) Installing musl-dev (1.2.2-r3)
(13/17) Installing libc-dev (0.7.2-r3)
(14/17) Installing g++ (10.3.1_git20210424-r2)
(15/17) Installing linux-headers (5.10.41-r0)
(16/17) Installing make (4.3-r0)
(17/17) Installing .build-dependencies (20211205.082423)
Executing busybox-1.33.1-r3.trigger
OK: 205 MiB in 43 packages
fetch https://dl-cdn.alpinelinux.org/alpine/v3.14/main/x86_64/APKINDEX.tar.gz
fetch https://dl-cdn.alpinelinux.org/alpine/v3.14/community/x86_64/APKINDEX.tar.gz
ERROR: unable to select packages:


  nginx-1.20.2-r0:
    breaks: world[nginx=1.20.1-r3]
  python3-3.9.5-r2:
    breaks: world[python3=3.9.5-r1]
Removing intermediate container ad00bd36b220
1 Like

Thanks @Three I just released a new version that should be fixed.
@alanmasu

Thanks man. It installed now you updated it.

1 Like

does this require SSL?

Hi, the installation worked fine for me. Connecting to the web-ui I’m prompted with a password request which and I cannot login. I tried every password. What can I do?

Hi there, I installed it but gets the following error in logs

2022/01/24 06:20:17 [error] 355#355: *1 connect() failed (111: Connection refused) while connecting to upstream, client: 172.30.32.2, server: a2b947f4-node-red-dashboard, request: "GET / HTTP/1.1", upstream: "http://172.30.32.1:1880/endpoint/ui/", host: "192.168.1.2:8123", referrer: "http://192.168.1.2:8123/hassio"
[24/Jan/2022:06:20:17 +0530] 502 172.30.32.2 192.168.1.4, 172.30.32.1(172.30.32.2) GET / HTTP/1.1 backend 172.30.32.1:1880 192.168.1.2 / 

seems you need to enable the networking for node red - addon-node-red/DOCS.md at de3f052b1bf4d00c5cef305c64240a6d644d8bcc · hassio-addons/addon-node-red · GitHub