[SOLVED] Hue custom component broke in 0.95.1

Just upgraded hassio to 0.95.1 and also updated the hue custom components, but receiving messages about ip address is invalid.

Anyone else?

2019-06-28 16:30:58 ERROR (MainThread) [homeassistant.config] Invalid config for [sensor.hue_custom]: [ip_address] is an invalid option for [sensor.hue_custom]. Check: sensor.hue_custom->ip_address. (See /config/configuration.yaml, line 141). Please check the docs at https://home-assistant.io/components/sensor.hue_custom/

Line 141 just has the IP address of my Hue hub like normal

If this is the component

the ip address on a line my itself is invalid. The 0.95 release notes said former warnings now become breaking changes.
Those who did not heed the warnings are now broken.

1 Like

this is the Custom component he’s using, and for that component the ip-address shouldn’t be there either anymore. Has been for a long time…

use this, and you’re set:

  - platform: hue_custom
  - platform: hue_custom

#  - platform: hue_custom

note I am not using the divide_tracker for now, because it has issues, as reported on the GitHub…
note2 I am not using platform: huesensor because I feel that is an incorrect name. This is the hue_custom component, for sensors, binary_sensors and device_trackers…

Doesn’t make any difference for the workings though, so I renamed it in my setup, just like OP does :wink:

1 Like

Thank you. Figured this out by just commenting out the lines and that’s fixed it. Weird entity issues in Node-Red, but I’m half way back to working. Thank you

Correct and I figured this out just by commenting out the IP and token lines.

Receiving entity_id errors in Node-Red, but I’ll keep hacking away to figure those tout. Thank you for the help.